Bug 508559 - defaults.list out of date for openoffice.org 3.1
defaults.list out of date for openoffice.org 3.1
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: shared-mime-info (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
: 517640 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-28 11:31 EDT by Edward Sheldrake
Modified: 2009-11-12 21:27 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.60-4.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-12 21:27:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward Sheldrake 2009-06-28 11:31:28 EDT
Description of problem:
All the defaults.list entries for OpenOffice.org programs have names such as openoffice.org-1.9-calc.desktop, but none of these files exist anymore with Fedora 11's OpenOffice.org, the 1.9 was removed (#486460), the files are now e.g. openoffice.org-calc.desktop, openoffice.org-writer.desktop.

As a result, gnumeric had become the default application for opening Excel .xls files on my system. Abiword had also taken over .doc files.

Version-Release number of selected component (if applicable):
shared-mime-info 0.60-3.fc11

How reproducible:
Always.

Steps to Reproduce:
1. Install openoffice.org-calc and gnumeric
2. Double click a .xls file in nautilus
3.
  
Actual results:
Gnumeric opens the spreadsheet.

Expected results:
OpenOffice.org calc opens the spreadsheet (it used to on Fedora 10).

Additional info:
Comment 1 Edward Sheldrake 2009-07-02 17:20:15 EDT
I think this is less reproducible, without correct entries in /usr/share/applications/defaults.list, which program ends up the default appears to be undefined.

There are more .desktop files in defaults.list that are not present:
gnome-gnumeric.desktop
gnome-abiword.desktop
brasero-ncb.desktop
gthumb-importer.desktop

Present files are:
fedora-gnumeric.desktop
fedora-abiword.desktop
brasero-nautilus.desktop
gthumb-import.desktop
Comment 2 Caolan McNamara 2009-08-17 07:17:07 EDT
*** Bug 517640 has been marked as a duplicate of this bug. ***
Comment 3 Bastien Nocera 2009-10-08 12:15:58 EDT
Thanks Edward for spotting all those, turns out we were still broken in F-12, which is pretty embarassing. Updated package is coming shortly.
Comment 4 Fedora Update System 2009-10-08 12:23:14 EDT
shared-mime-info-0.60-4.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/shared-mime-info-0.60-4.fc11
Comment 5 Fedora Update System 2009-10-13 21:34:15 EDT
shared-mime-info-0.60-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update shared-mime-info'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10405
Comment 6 Fedora Update System 2009-11-12 21:27:04 EST
shared-mime-info-0.60-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.