Bug 508832 - Changes to printing beat
Changes to printing beat
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: release-notes (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: John J. McDonough
Karsten Wade
:
Depends On:
Blocks: fc-relnotes-traqr
  Show dependency treegraph
 
Reported: 2009-06-30 02:39 EDT by Niranjan Mallapadi Raghavender
Modified: 2010-01-11 14:39 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-11 14:39:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Niranjan Mallapadi Raghavender 2009-06-30 02:39:27 EDT
Provide details here.  Do not change the blocking bug.
Addition of changes of cupsd package apart from system-config-printer.


The version of cups provided with Fedora is cups-1.4 and following are the features in general,  Though there are about number of changes <br> 

====Web-Interface====
*The Administration Page provides more Advanced Operations like choice of Protocols (CUPS, LDAP) for sharing, Maximum number of
simultaneous clients , Shows Job Completed jobs

====Networking====
* CUPS now uses "Bonjour (DNS-SD)" providing mDNS(multicast DNS) which supports Bonjour-based printer discovery

====Scheduler====
*Scheduler now adds "authenticated" policy, So that certain IPP operations can be authenticated.On Fedora-11 the default policy is "default" 
The scheduler provides "OpPolicy" directive which can be used to modify the policy.  lpadmin command can also be used to set the policy to<br> 
a particular printer using <code>-o printer-op-policy</code>
*the default LogLevel is now "warn" instead of "info"
*The scheduler now supports a DefaultPaperSize directive to override the default paper size defined by the locale or libpaper configuration
*New ErrorPolicy "retry-current-job" is added, that retries the current job immediately 
*Scheduler supports SSLOptions Directive in cupsd.conf which specifies the network address and port to Listen for secure connections
*Scheduler now supports new "FatalErrors" Directive to determine which kind of errors are fatal, The following kind of errors are currently recognized 
none, all, browse, config (configuration syntax errors), log (log file creation errors), permissions (file permission errors ex: certificate files and keys)
*Scheduler now passes hostname from the job was submitted as "job-originating-host-name" to filters and back-ends 
*Scheduler now includes CUPS_FILETYPE, PRINTER_INFO, and PRINTER_LOCATION environment variables that is passed to filter or backend
*The scheduler now supports a test mode via the "-t" option, which can be used to test the syntax of cupsd.conf.
Comment 1 Niranjan Mallapadi Raghavender 2009-06-30 02:41:08 EDT
docs
Comment 2 Niranjan Mallapadi Raghavender 2009-06-30 02:42:15 EDT
*docs*
Comment 3 eric@christensenplace.us 2009-06-30 10:57:12 EDT
*** Bug 508025 has been marked as a duplicate of this bug. ***
Comment 4 John J. McDonough 2009-07-17 10:48:00 EDT
rev 1.8
Comment 5 Fedora Update System 2010-01-03 11:39:33 EST
fedora-release-notes-11.0.4-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/fedora-release-notes-11.0.4-1.fc11
Comment 6 Fedora Update System 2010-01-06 19:53:18 EST
fedora-release-notes-11.0.4-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.