Bug 508837 - [PATCH] Use hashlib instead of deprecated module 'md5'
[PATCH] Use hashlib instead of deprecated module 'md5'
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: python-cheetah (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Mike Bonnet
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-30 04:13 EDT by Juha Tuomala
Modified: 2009-09-15 15:32 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 480945
Environment:
Last Closed: 2009-09-15 15:32:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juha Tuomala 2009-06-30 04:13:49 EDT
+++ This bug was initially created as a clone of Bug #480945 +++

Description of problem:
The problem looks same as bz#475871.

Cheetah uses deprecated module 'md5' and thus DeprecationWarning warning message will be printed. Here is an example log:

foo@localhost% echo "from Cheetah import CacheRegion" | python -                    ~
/usr/lib/python2.6/site-packages/Cheetah/CacheRegion.py:30: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import md5
foo@localhost%


Version-Release number of selected component (if applicable):
python-cheetah-2.0.1-4.fc11.x86_64

How reproducible: always if Cheetah.CacheRegion is imported


Steps to Reproduce:
try 'echo "from Cheetah import CacheRegion" | python -'

  
Actual results: See the log above.


Expected results: no warning message


Additional info:

--- Additional comment from ssato@redhat.com on 2009-01-21 09:25:12 EDT ---

Created an attachment (id=329608)
Patch to make use of hashlib instead of md5 module

It might depend on python >= 2.6.

--- Additional comment from mikeb@redhat.com on 2009-01-21 09:51:16 EDT ---

This is really a change that would need to be made upstream.  Also, in order to support older versions of python I think you'd have to fall back to md5 if hashlib isn't available.  You probably want to post a patch to

cheetahtemplate-discuss@lists.sourceforge.net

--- Additional comment from ssato@redhat.com on 2009-01-26 13:46:53 EDT ---

(In reply to comment #2)
> This is really a change that would need to be made upstream.  Also, in order to
> support older versions of python I think you'd have to fall back to md5 if
> hashlib isn't available.  You probably want to post a patch to
> 
> cheetahtemplate-discuss@lists.sourceforge.net

Absolutely right. I just took second best :P
I posted an updated patch to that list. thanks for letting me know that list!

Also, I will attach that patch here for the record.

--- Additional comment from ssato@redhat.com on 2009-01-26 13:47:48 EDT ---

Created an attachment (id=330020)
Updated patch posted to the upstream mailing list

--- Additional comment from jamundso@gmail.com on 2009-02-13 11:28:46 EDT ---

*** Bug 485445 has been marked as a duplicate of this bug. ***

--- Additional comment from ssato@redhat.com on 2009-03-19 01:18:10 EDT ---

FYI. 

"Cheetah Community Edition v2.1.0" looks including my fix.

--- Additional comment from fedora-triage-list@redhat.com on 2009-06-09 06:49:01 EDT ---


This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

--- Additional comment from tuju@iki.fi on 2009-06-30 04:09:24 EDT ---

http://koji.fedoraproject.org:80/koji/packageinfo?packageID=3568
 There are already builds for 2.2.1

https://admin.fedoraproject.org/updates/search/python-cheetah
 This update (f11) has been submitted for stable

I guess this one could be closed. How about f10, it still appears to have 2.0.1.
Comment 1 Mike Bonnet 2009-06-30 09:26:24 EDT
I'm a little bit uncomfortable pushing this to F-10 at this point in the product lifecycle because it is a major version (in fact, 2 major versions) upgrade, with some significant changes under the covers.  How comfortable are people that this won't break existing installations or dependent packages?
Comment 2 Juha Tuomala 2009-06-30 09:37:19 EDT
(In reply to comment #1)
> I'm a little bit uncomfortable pushing this to F-10

I suggest that discussion should take place in cloned bug 508837.
Comment 3 Juha Tuomala 2009-06-30 09:38:21 EDT
errr.... *this* is the bug :) damn those copy_all_comments scripts....
Comment 4 Michael DeHaan 2009-08-13 11:07:23 EDT
Fedora 11 still seems to have this problem.  Can we get an update please?
Comment 5 Mike Bonnet 2009-09-15 15:32:29 EDT
An update is being pushed through F-11 to address this issue.  I don't think pushing this update to F-10 at this point in the product lifecycle is appropriate, so I'm closing this bug WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.