Bug 50899 - Unresolved Dependencies in upgrade show no suggestion
Unresolved Dependencies in upgrade show no suggestion
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: distribution (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-04 13:09 EDT by Jeff Lane
Modified: 2007-04-18 12:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-10 20:13:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upgrade.log from upgrade from Seawolf to Roswell (52.35 KB, text/plain)
2001-08-04 13:10 EDT, Jeff Lane
no flags Details

  None (edit)
Description Jeff Lane 2001-08-04 13:09:18 EDT
Description of Problem:
while doing an upgrade from Seawolf on my laptop, when I get to the
Unresolved Dependencies screen, several packages are listed as having
unresolved dependencies, however under the requirements column, the
requirement listed for each one is "No Suggestion"

How Reproducible:
Not sure...  perhaps by selecting the listed packages during upgrade would
cause same result.

The upgrade.log, showing what was upgraded, is attached.  if you need, I
will also send a rpm -qa showing all installed packages....
Comment 1 Jeff Lane 2001-08-04 13:10:41 EDT
Created attachment 26231 [details]
upgrade.log from upgrade from Seawolf to Roswell
Comment 2 Peter Bowen 2001-08-05 11:46:53 EDT
This also showed up on my laptop during the upgrade from Zoot to Roswell.  The
unresolved deps screen was caused by foreign (non-Red Hat provided) packages
being installed on my system.  

All the packages listed had 'no suggestion' listed under 'Requirement'.  Even
though there were not any packages to potentially install, there was still an
option to 'Install packages to satisfy dependencies'.  Choosing this option has
the same result as choosing 'Ignore package dependencies': unsatisified deps on
the machine post-install.  Additionally, the option 'Do not install packages
that have dependencies' does not make sense, as the listed packages are already
installed on the system.

I realize that this screen has existed as long as anaconda has existed, but it
could be confusing to users who are not familiar with RPM dependencies.  This
screen seems unnecessary unless the user has selected 'Customize packages to be
 upgraded' or 'Select individual packages' as there is never an option for the
end user -- if they want a functional system, the dependencies must be resolved.
 The only time it seems reasonable to show the screen is when the user has
chosen to select individual packages.

Could anaconda not show the 'Unresolved Dependencies' screen unless the user has
manually selected packages?  Otherwise it would just automatically choose
'Install packages to satisfy dependencies' and skip the screen.
Comment 3 Bill Crawford 2001-08-08 08:20:46 EDT
Um, can I add a request/suggestion: how about an option to REMOVE existing
packages that will have unsatisfied dependencies?
Also, how about including some older compat-libs such as for 4.x and 5.x? 
FreeBSD installs allow you to select compatability libraries for 2 or 3 previous
versions.
Comment 4 Jeff Lane 2001-08-08 18:31:19 EDT
Actually, I had suggested part of that at one time.  I think it would be really
great to at least have the ability to select individual packages in the
dependency screen, instead of the current All or None choice.  i.e. the list
shows packages foo, bar, jack, jill, and bob.  and I decide then to just not
install bob but keep all the others.. there should be a way for me to choose to
not install bob, but keep all the others without having to go back to package
selection to find that one package.
Comment 5 Brent Fox 2001-08-10 18:24:06 EDT
Ok, we're talking about a few different issues here. One is that the package
dependency screen needs some work. That can't be done in the current release
time frame, but perhaps in the future. The original issue here is that some
packages have messed up dependencies. This is a packaging issue and not an
installer issue. We need the list of offending packages so that they can be
fixed (they probably already have been since roswell)  Changing component to
'distribution'.
Comment 6 Peter Bowen 2001-08-10 20:13:31 EDT
I have split my issue out into Bug #51489.  I did not have any packages that
were provided by Red Hat that has dependency problems.  Upgrading from 6.x to
7.x does break binary compatibility, and, therefore, 3rd party packages are not
expected to have correct deps for 7.x if built for 6.x
Comment 7 Preston Brown 2001-08-13 16:15:34 EDT
So there is no distribution problem per-se, and the installer is being worked 
on.  Case closed.

Note You need to log in before you can comment on or make changes to this bug.