Bug 50904 - Installer does not seem to install Grub
Installer does not seem to install Grub
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
roswell
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-04 13:57 EDT by Brian Schmidt
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-07 22:45:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Schmidt 2001-08-04 13:57:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010725

Description of problem:
This bug is similar to Bug 50800 (and a little like 50821), although my
results differ.  It seems that Grub does not actually get installed to my
MBR during installation.  It never crashes on me, though, as it has to
other people.  I tried this install 4 times.  Twice using the GUI, twice
using the text installer.  Each with the same result.  I have Win2000 on
hda and Linux on hdb.  The first attempt, I got an LI response on boot. 
This is left over from the Seawolf copy I had installed that I over-wrote
to test Roswell.  I went back and used a DOS boot floppy to fdisk /mbr so
that I could get back into Windows at least.  From there, the last 3
subsequent attempts offered no boot option and it went straight into
Windows.  It seems to have never written to the boot record.  Using the
boot floppy I created during the install gave me this result: could not
find kernel image: linux.  After finding 2 bugs listed here related to
Grub, I decided on the 5th attempt to use LILO.  Lo and behold, everything
worked just fine and my system booted up my Linux disk as expected.  I am
assuming this is a problem with the installer, since it "appears" that Grub
never makes it to the boot record during the install.

How reproducible:
Always

Steps to Reproduce:
1. Install
2. Choose Grub option for bootloader
3. Reboot
4. It's not there
	

Actual Results:  The system appears to boot using whatever was previously
in the MBR.  In my case, the first time being a previous LILO, then later
just to Windows after I had restored the MBR with fdisk /mbr earlier to get
back into that drive.

Expected Results:  It should have brought some sort of menu from Grub
(don't know what exactly; I've only used LILO in the past) to boot one of
my systems.

Additional info:

1GHz Athlon
Abit KT7
320MB RAM
1 CD-ROM / 1 CD-RW
2 Hard drives
  - 40GB each
  - hdb partitioned with /, /boot, swap
  - hda single partition for Windows 2000 (FAT32)
  - Not using Windows NT bootloader, since it's FAT32 and I really don't
care if Windows doesn't come up ;)
3.5" floppy
ATI Radeon (AGP) VIVO
Comment 1 Glen Foster 2001-08-06 18:52:18 EDT
We (Red Hat) really need to fix this defect before next release.
Comment 2 Jeremy Katz 2001-08-07 16:50:26 EDT
Could you attach your /boot/grub/grub.conf and /boot/grub/device.map files? 
(they get generated even if you use LILO as your bootloader)
Comment 3 Brian Schmidt 2001-08-07 22:45:37 EDT
Unfortunately, since it's been a few days and kept me out of my system, I went
back and wiped that configuration out and restored a previous set-up.  Is there
anything that is contained in those configuration files that I can relay somehow
else?  Such as partitions, etc?  All of that is still set up the same.  Or were
these needed to see how grub tried to affect the boot process?
Comment 4 Jeremy Katz 2001-08-07 22:52:38 EDT
From what you've given, this should be fixed in CVS

Note You need to log in before you can comment on or make changes to this bug.