Bug 50914 - Problems using Konqueror to copy files from SMB server.
Problems using Konqueror to copy files from SMB server.
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Aaron Brown
:
: 50915 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-04 14:53 EDT by matthew
Modified: 2007-04-18 12:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-19 09:32:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description matthew 2001-08-04 14:53:53 EDT
Description of Problem:
I am trying to copy a directory of MP3 files from a file server on my
network.  Several files will copy but then it stops and the smbclient
process that kde is using to do the work is using 100% cpu while nothing is
getting done.  I have to mannually kill the copy window, and kill the
smbclient processes before my system is running OK again.

How Reproducible:
Almost every time, as long as there are enough files, a few directories
with only one or two file seem to work most of the time.

Steps to Reproduce:
1. Open konqueor to a smb share (smb://fileserver/share/mp3dir)
2. Drag a folder that contains files (I did this with mp3 files) to the
desktop (or any folder).
3. Let it start copying and it will fail eventually.

Actual Results:
A few files were copied but not all.

Expected Results:
All files in the folder, and sub folders should have been copied to my system.

Additional Information:
Tried this connecting to both a windows file server and a redhat 7.1 file
server running a hand compiled samba 2.2
Comment 1 Bernhard Rosenkraenzer 2001-08-04 15:20:26 EDT
Does the same thing happen if you mount the filesystem using the mount 
command and then access it in konqueror by going to the mount point?
Comment 2 Bernhard Rosenkraenzer 2001-08-04 17:56:22 EDT
*** Bug 50915 has been marked as a duplicate of this bug. ***
Comment 3 matthew 2001-08-05 04:17:20 EDT
As requested, I mount the smb server with an smbmount command.  I have seen no 
problems when doing this.

Also, after further testing what I'm seeing is that in many situations the 
smbclient process that is serving the smb ioslave stays around after I am done 
browsing the smb share, or done copying files.  When it sticks around it 
starts to use 100& CPU.  Also, at one point the copy operation was reporting 
that it was "stalled" I hit cancel, and cpu usage went to 100% from the 
smbclient.
Comment 4 Mike McLean 2003-01-02 14:07:12 EST
This bug has been inappropriately marked MODIFIED. Please review the bug life
cycle information at 
http://bugzilla.redhat.com/bugzilla/bug_status.cgi

Changing bug status to ASSIGNED.
Comment 5 matthew 2003-02-18 01:00:21 EST
I still have problems using konqueror to browse smb shares.  No matther what
version of Redhat I have tried, be it the roswell beta, RH7.3 or RH8.0, smb
browsing does not work well at all with konqueror.  Is it just me?
Comment 6 Ngo Than 2003-06-19 09:32:00 EDT
please try kde-3.1.1a or newer, which you find it on ftp.kde.org. It should fix
this problem

Note You need to log in before you can comment on or make changes to this bug.