Bug 509204 - Fence_scsi limitaions
Fence_scsi limitaions
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Cluster_Administration (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: Steven J. Levine
Content Services Development
: Documentation
Depends On:
Blocks: 512998 513072
  Show dependency treegraph
 
Reported: 2009-07-01 14:29 EDT by Toure Dunnon
Modified: 2016-04-26 09:39 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 512998 513072 (view as bug list)
Environment:
Last Closed: 2009-07-23 09:29:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
First page to review from admin guide (416.51 KB, application/postscript)
2009-07-21 14:39 EDT, Steven J. Levine
no flags Details
Second page to review from admin guide (407.59 KB, application/postscript)
2009-07-21 14:39 EDT, Steven J. Levine
no flags Details

  None (edit)
Description Toure Dunnon 2009-07-01 14:29:14 EDT
Description of problem:
Customers who configure a cluster with only two nodes and use fence scsi do not
realize that two member configurations are not supported, as there are problems with network partitions.

Version-Release number of selected component (if applicable):
RHEL5

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
No documentation on fence_scsi limitations....

Expected results:
Docs with such information:
4 Limitations

In addition to these requirements, fencing by way of SCSI persistent reservations also some limitations. 

--Multipath devices are currently only supported for RHEL 5.0 and later with the use of device-mapper-multipath. 

--All nodes in the cluster must have a consistent view of storage. In other words, all nodes in the cluster must register with the same devices. This limitation exists for the simple reason that each node must be able to remove another node's registration key from all the devices that it registered with. I order to do this, the node performing the fencing operation must be aware of all devices that other nodes are registered with. If all cluster nodes have a consistent view of storage, this requirement is met.
 
--Devices used for the cluster volumes should be a complete LUN, not partitions. SCSI persistent reservations work on an entire LUN, meaning that access is controlled to each LUN, not individual partitions. 

--As with other SAN fencing agents, fence_scsi cannot be used in a 2-node cluster. 


Additional info:
Comment 3 Steven J. Levine 2009-07-06 10:25:54 EDT
I'm looking at how we might add this list of limitations as a note to the section of the cluster admin guide where we mention that SCSI fencing is one of the fence devices that you can configure (although we don't currently document much more than that). We also provide a table of fence SCSI parameters, and I can reference the limitations there as well, or at least point to where we describe them.

But my question is: Should this information go in the fence_scsi man page?  That is currently where SCSI fencing is documented, and is probably where people go for information on configuring SCSI fencing.
Comment 4 Steven J. Levine 2009-07-07 10:34:17 EDT
I have opened BUG 510042 as a separate bug to note that these limitations are not documented in the fence_scsi man page.
Comment 5 Steven J. Levine 2009-07-07 11:33:46 EDT
The fence_scsi limitations are documented here, it turns out:

http://sources.redhat.com/cluster/wiki/SCSI_FencingConfig

So the issue may be how to be sure people see that info.
Comment 6 Perry Myers 2009-07-07 12:09:19 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
*** DRAFT ***
Need to create kbase article based on:
http://sources.redhat.com/cluster/wiki/SCSI_FencingConfig

And mention this kbase in release notes

*** DRAFT ***
Comment 7 Paul Kennedy 2009-07-07 17:40:42 EDT
Changed component to Cluster_Administration. The previous component selected was not specific enough.
Comment 8 Steven J. Levine 2009-07-08 15:16:48 EDT
I have filed BUG 510353 to separate out the kbase article request from this bug. This bug will be closed when I add the information to the Cluster Admin Guide.
Comment 10 Perry Myers 2009-07-08 21:35:13 EDT
Deleted Release Notes Contents.

Old Contents:
*** DRAFT ***
Need to create kbase article based on:
http://sources.redhat.com/cluster/wiki/SCSI_FencingConfig

And mention this kbase in release notes

*** DRAFT ***
Comment 22 Steven J. Levine 2009-07-21 14:38:36 EDT
To jwest@redhat.com:

I have added a note about SCSI fence limitations in two places to a draft version of a RHEL 5.3 update of the cluster admin guide, which are the places we mention SCSI fencing.

- Section 3.5, Configuring Fence Devices, in the chapter on Configuring Red Hat Cluster with Conga. I will attach this to the next comment as fencedevice1.ps.

- At the end of Table B.15 in Appendix B, where we list the parameters for the fence devices. I will attach this to a subsequent comment as fencedevice2.ps.
Comment 23 Steven J. Levine 2009-07-21 14:39:13 EDT
Created attachment 354546 [details]
First page to review from admin guide
Comment 24 Steven J. Levine 2009-07-21 14:39:40 EDT
Created attachment 354547 [details]
Second page to review from admin guide
Comment 25 Steven J. Levine 2009-07-21 14:40:39 EDT
To jwest@redhat.com:

Let me know if this description is ok and I'll check this in and try to get this pushed out to redhat.com asap.
Comment 30 Paul Kennedy 2009-07-21 16:38:29 EDT
Fix is being applied to version 5.3; changing version to 5.3
Comment 32 Paul Kennedy 2009-07-22 08:37:03 EDT
Changes checked in. Requested push to redhat.com docs page.
Comment 34 Paul Kennedy 2009-07-23 09:29:43 EDT
Updated document is available. Changes listed as attachments earlier are in section 3.5 and appendix B on the redhat.com docs page:

http://www.redhat.com/docs/manuals/enterprise/#RHEL5

Note You need to log in before you can comment on or make changes to this bug.