Bug 50923 - Shouldn't require ttfonts-ja
Shouldn't require ttfonts-ja
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ghostscript (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Aaron Brown
:
: 53660 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-04 17:44 EDT by Bernhard Rosenkraenzer
Modified: 2007-04-18 12:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-10 04:53:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bernhard Rosenkraenzer 2001-08-04 17:44:53 EDT
ghostscript requires ttfonts-ja - why? ghostscript is perfectly usable
without it if you don't ever plan to print japanese text (like maybe 90% of
our users).
Comment 1 Crutcher Dunnavant 2001-08-08 22:34:32 EDT
I dont care if you dont want to print japanese. Ghostscript is compiled needing
those fonts. We had this discussion for 7.1, I am not changing it.
Comment 2 Bernhard Rosenkraenzer 2001-08-09 03:35:39 EDT
No it isn't. Try for yourself:

- rpm -e --nodeps ttfonts-ja
- print any non-Japanese document
- watch it working.


Comment 3 Chris Ricker 2001-11-01 10:27:24 EST
I definitely agree with Bero.  Ghostscript works just fine w/o ttfonts-ja, and
now that there's a separate Japanese disc-1 there's no reason not to make a
ghostscript-ja that depends on ttfonts-ja if you absolutely feel that it's
necessary.

I just did an up2date.  It snarfed down the ghostscript from errata.  It then
snarfed down an absofsckinglutely useless 9 megs ttfonts-ja rpm for me which I
promptly rpm'ed -e --nodeps after the ghostscript update....  It's wasting my
space, and it's wasting RH's bandwidth and my bandwidth to have this dependency
which, AFAIK, has no technical basis.
Comment 4 Alejandro Gonzalez Hernandez - Imoq 2001-12-03 17:06:32 EST
Downloading 9 megs at 56K can be soooo sloooooooooooooooooooooowwwww!

I would really appreciate to get this fixed.
Comment 5 Tim Waugh 2002-01-10 04:53:41 EST
*** Bug 53660 has been marked as a duplicate of this bug. ***
Comment 6 Bernhard Rosenkraenzer 2002-01-21 07:39:40 EST
Fixed in 6.52-1

Note You need to log in before you can comment on or make changes to this bug.