Bug 509246 - packages installed through SDC are still marked for Install in SSM
packages installed through SDC are still marked for Install in SSM
Status: CLOSED DEFERRED
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Dobies
Red Hat Satellite QA List
:
Depends On:
Blocks: 462714
  Show dependency treegraph
 
Reported: 2009-07-01 16:54 EDT by Preethi Thomas
Modified: 2014-07-04 09:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-04 09:23:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2009-07-01 16:54:21 EDT
Description of problem:

packages installed through SDC are still marked for install in SSM.

Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL5-re20090625.0-i386-embedded-oracle.iso

How reproducible:


Steps to Reproduce:
1.register a client
2.install a package through SDC eg; agg
3.select that system
4. go to SSM->Packages->Install->Install New Packages
5. Select the channel name
6. Look for the package name that was installed from step 2

  
Actual results:
packages that are installed through SSM are listed in the Install Package list.

Expected results:
Only packages that are not installed on the system should be displayed in the install package list.

Additional info:
Comment 1 Clifford Perry 2009-07-01 22:32:13 EDT
This needs further review/understanding. Could be client side bug not sending back the package change correctly, or somehow not being displayed correctly in UI. Does SDC show this, while SSM does not, maybe wording and queries different. 

Cliff
Comment 2 Clifford Perry 2009-07-01 22:59:07 EDT
Think this is a dupe or bug 509268
Comment 3 Jay Dobies 2009-07-07 13:17:21 EDT
This is the behavior in 5.1.1 as well.

I'm pretty sure it's that the query the SSM code uses to list all possible packages to install does not take into account what's already installed. The logic would be to list the package if at least one system in the SSM does not have the package installed, however I feel like I've explored this before and that logic was tricky (at best) to implement. I'll dig further and see if I can find a reason why this logic isn't present.
Comment 4 Clifford Perry 2009-07-07 13:21:04 EDT
At this late stage of the release I am going to move off the release, since it is not a Regression to pass releases, sounds like a bug we need to review and address early on in next cycles. 

Cliff

Note You need to log in before you can comment on or make changes to this bug.