Bug 50926 - athlon kernel oopses on T-Bird
athlon kernel oopses on T-Bird
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-04 17:51 EDT by Berd Dahlmo
Modified: 2007-04-18 12:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 07:30:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci (947 bytes, text/plain)
2001-08-05 12:14 EDT, Berd Dahlmo
no flags Details
lspci -n (459 bytes, text/plain)
2001-08-05 12:15 EDT, Berd Dahlmo
no flags Details
lspci (dib) (796 bytes, text/plain)
2001-08-06 09:19 EDT, Doerte Elbad
no flags Details
lspci -n (dib) (412 bytes, text/plain)
2001-08-06 09:20 EDT, Doerte Elbad
no flags Details
lspci from Bjarke (1.18 KB, text/plain)
2001-08-17 15:03 EDT, Bjarke Skjernaa
no flags Details

  None (edit)
Description Berd Dahlmo 2001-08-04 17:51:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010725

Description of problem:
When installing Roswell on an AMD T-Bird 950 equipped machine, the
installer installed kernel-2.4.6-3.1.athlon.rpm. This kernel caused my
machine to constantly oops. I never managed to finish a boot with this
kernel, it always crashed during loading, at different places.

Installing the i686 kernel fixed the problem and my system now appears stable.

How reproducible:
Sometimes

Steps to Reproduce:
1. Install Roswell on an AMD T-Bird machine
2. Boot

Actual Results:  Lots of oopses at random points during startup

Expected Results:  Complete system boot

Additional info:
Comment 1 Doerte Elbad 2001-08-05 10:32:18 EDT
Same here on a 1,26 GHz Athlon (9,5*133)
VIA KT133A, 512MB PC133 RAM, RIVA TNT2 Ultra, no NIC

Installed Roswell cleanly on formated ext2 partitions.
The kernel just oops on several stages of init processes.
Most common failure message is a problem with "InterruptHandler".
Not one boot could be finished.
Had the same problems with 7.1 after compiling Kernel
"Athlon"-optimized. Just oops on boot process.
ix86 build kernels work.
Comment 2 Arjan van de Ven 2001-08-05 11:14:42 EDT
There have been several similar reports on the linux-kernel mailinglist, and so
far it appears to be a hardware problem. Do you know how many Watts your
powersupply is ? What brands are the motherboards ?
Comment 3 Berd Dahlmo 2001-08-05 11:49:56 EDT
My psu is 250 watts iirc, mb is a ABIT KT7A / VIA KT 133A. 256 MB ram.
Comment 4 Arjan van de Ven 2001-08-05 11:51:55 EDT
Could you also give the "lspci" and "lspci -n" outputs ?
We might end up not installing the athlon kernel on certain VIA chipsets and
that info would help us a great deal in determining which ones. Thanks a lot for
helping so far!
Comment 5 Berd Dahlmo 2001-08-05 12:14:28 EDT
Created attachment 26314 [details]
lspci
Comment 6 Berd Dahlmo 2001-08-05 12:15:21 EDT
Created attachment 26315 [details]
lspci -n
Comment 7 Doerte Elbad 2001-08-06 09:17:10 EDT
My PS is a 235W one, my motherboard is a SOLTEK SL-75KAV Rev. 8.1
lscpi[-n] follow.
Comment 8 Doerte Elbad 2001-08-06 09:19:25 EDT
Created attachment 26413 [details]
lspci (dib)
Comment 9 Doerte Elbad 2001-08-06 09:20:54 EDT
Created attachment 26414 [details]
lspci -n (dib)
Comment 10 Arjan van de Ven 2001-08-06 09:23:32 EDT
ehm... did anyone ever mention 235W is a very very small PSU for an athlon box ?
Comment 11 redtux 2001-08-06 12:23:55 EDT
I had a similar problem with an Athlon 750.
It stalled at loading ram image.
This was after choosing lilo as boot loader

To solve it I had to do an upgrade choosing grub
Comment 12 Berd Dahlmo 2001-08-06 14:33:48 EDT
I've doubleckecked my PSU, its 300W, so I think we can rule PSU problems out.
Comment 13 Glen Foster 2001-08-06 18:41:46 EDT
We (Red Hat) should try to fix this for the next release.
Comment 14 Doerte Elbad 2001-08-07 07:27:47 EDT
I checked the the PSU and 235W works definetly for me.
I just ripped out all possible PCI devices, same boot result. (oops)
The reason here is not lilo or grub - boot from a floppy.
As mentioned - with a ix86 kernel the box runs for days without a
problem. Tried also hours of hiloads, no problems. The CPU got 530C
constantly after hours.
For me it looks like a prob in gcc "athlon" optimized code.
I couldn4t got just one app running compiling with "athlon".
"i686" works great.
Comment 15 Arjan van de Ven 2001-08-07 08:07:43 EDT
We really don't think this is a gcc problem. The athlon kernel puts bigger
stress on your system-components, and some machines don't seem to cope with
that. 99.9% of the athlons just work, with the exact same kernel image.

Why some systems fail is still a mystory.
Comment 16 Doerte Elbad 2001-08-07 08:38:46 EDT
Now, like baard wrote, the PSU is not the problem.
Just bought a 400W one, 300W was not on stock.
Tried it, same results.
So it seems to be a component problem. Strange.
Maybe still problems with VIA support.
Comment 17 Arjan van de Ven 2001-08-07 08:50:02 EDT
VIA is somehow involved; all people with problems were running VIA chipsets.
But while a cow is an animal, not all animals are cows.....
Comment 18 Mouillart 2001-08-10 05:38:31 EDT
I've look that you have a sound blaster live installed.I have the same probleme
has you explained in bug 51371, when i remove the sound blaser live all work fine.
Comment 19 Arjan van de Ven 2001-08-17 05:46:03 EDT
Since it's unlikely that we'll get to the bottom of this, I added a commandline
option to the athlon kernel to disable the athlon optimisations, so people who
have problems can at least boot their system (and maybe get the i686 kernel
installed).
Comment 20 Bjarke Skjernaa 2001-08-17 15:01:41 EDT
I have the same problem (and yes it's a VIA chipset).

CPU: 1200 MHz Athlon
Motherboard: Microstar K7T Turbo
RAM: 2x256 MB

Adding attachment with lspci.
Comment 21 Bjarke Skjernaa 2001-08-17 15:03:04 EDT
Created attachment 28334 [details]
lspci from Bjarke
Comment 22 Warren Togami 2001-09-29 04:36:22 EDT
Same problems here on the Asus A7VI-VM motherboard and 1.2GHz Athlon-C 
(12x100fsb).  This board has the VIA KM133 chipset, which is the KT133A with 
onboard S3 Savage video.

I have found that if I explicitly set my RAM to 133MHz, kernel oopses and IDE 
timeouts occur very frequently.  If I set it to 100MHz, it runs flawlessly.   
Most Athlon motherboards allow you to independently set the MHz frequency in 
relation to the FSB frequency.  Many of my friends with all sorts of other 
Athlon chipsets have no problems with Linux on their machines when RAM is 33MHz 
faster than the FSB.

This occurs with both the Roswell 1 and 2 default kernel.  Same results on four 
identical motherboards (I bought eleven of them.)  Strangely, my friend who 
bought one of these machines from me says that Mandrake 8.0 works flawlessly 
even with the 133MHz RAM setting.  I'm testing this next.

Asus A7VI-VM Motherboard
http://www.asus.com/products/Motherboard/socketa/a7vi-vm/
Comment 23 Alan Cox 2003-06-05 07:30:29 EDT
Closing. VIA eventually provided workarounds for PCI fixups and they are in the
kernels
that are errata or shipping for all supported Red Hat Linux now.

Note You need to log in before you can comment on or make changes to this bug.