This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 509374 - gnome-autogen.sh is not prepared to keep up with latest automake release
gnome-autogen.sh is not prepared to keep up with latest automake release
Status: CLOSED DUPLICATE of bug 508890
Product: Fedora
Classification: Fedora
Component: gnome-common (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Toshio Ernie Kuratomi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-02 10:13 EDT by karl kleinpaste
Modified: 2009-07-06 14:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-06 14:40:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description karl kleinpaste 2009-07-02 10:13:41 EDT
Description of problem:
gnome-autogen.sh is looking for now-out-of-date components, due notably to the new automake-1.11 package.

Version-Release number of selected component (if applicable):
$ rpm -qf /usr/bin/gnome-autogen.sh 
gnome-common-2.26.0-1.fc11.noarch
$ egrep gnome-common\|automake /var/log/rpmpkgs
automake-1.11-2.fc11.noarch.rpm
automake14-1.4p6-18.fc11.noarch.rpm
automake15-1.5-26.noarch.rpm
automake16-1.6.3-15.noarch.rpm
automake17-1.7.9-12.noarch.rpm
gnome-common-2.26.0-1.fc11.noarch.rpm

How reproducible:
Completely consistently.

Steps to Reproduce:
REQUIRED_AUTOMAKE_VERSION=1.9 . gnome-autogen.sh
  
Actual results:

automake 1.9 and 1.10 are gone, so...

checking for automake >= 1.9...
  testing automake-1.10... not found.
  testing automake-1.9... not found.
***Error***: You must have automake >= 1.9 installed

Expected results:

"duh"

Additional info:

gnome-autogen.sh uses this test for a valid automake version.

case $REQUIRED_AUTOMAKE_VERSION in
    1.4*) automake_progs="automake-1.4" ;;
    1.5*) automake_progs="automake-1.10 automake-1.9 automake-1.8 automake-1.7 automake-1.6 automake-1.5" ;;
    1.6*) automake_progs="automake-1.10 automake-1.9 automake-1.8 automake-1.7 automake-1.6" ;;
    1.7*) automake_progs="automake-1.10 automake-1.9 automake-1.8 automake-1.7" ;;
    1.8*) automake_progs="automake-1.10 automake-1.9 automake-1.8" ;;
    1.9*) automake_progs="automake-1.10 automake-1.9" ;;
    1.10*) automake_progs="automake-1.10" ;;
esac

A temporary hack workaround is to symlink both automake-1.11 and aclocal-1.11 to equivalent 1.10 names.
Comment 1 Toshio Ernie Kuratomi 2009-07-06 14:40:51 EDT

*** This bug has been marked as a duplicate of bug 508890 ***

Note You need to log in before you can comment on or make changes to this bug.