Bug 509478 - support IME-based hotkeys
support IME-based hotkeys
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
16
All Linux
low Severity medium
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
: FutureFeature, i18n, MoveUpstream
: 674728 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-02 22:25 EDT by Jens Petersen
Modified: 2011-09-01 05:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-01 05:53:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch for ibus/data/ibus.schemas.in (546 bytes, patch)
2009-11-04 01:01 EST, fujiwara
no flags Details | Diff

  None (edit)
Description Jens Petersen 2009-07-02 22:25:12 EDT
Description of problem:
ibus should really support IME-based trigger hotkeys like Windows.

Steps to Reproduce:
1. Run ibus in F11
2. ibus-setup -> hotkeys
  
Actual results:
Too many hotkeys defined for all for CIJK

Expected results:
Only hotkeys for IMEs in use to be available.
Eg Japanese user should only have Alt-` and Hankaku_Zenkaku
defined by default, not other keys like Ctrl-Space and
Korean hotkeys, etc.

Additional info:
With this change we could also drop defining a global
hotkey by default which would be ibus more acceptable
as a desktop default in the longer term.
Comment 1 fujiwara 2009-11-04 01:01:55 EST
Created attachment 367410 [details]
Patch for ibus/data/ibus.schemas.in

E.g. the attached patch can define the behavior with .po file.

msgid "[Control+space]"
msgstr "[Control+space,Zenkaku_Hankaku,Alt+Zenkaku_Hankaku]"
Comment 2 Jens Petersen 2010-06-30 01:29:24 EDT
That would be locale specific but may be an improvement.
Comment 3 fujiwara 2010-07-28 04:13:46 EDT
Hmm.., new EngineDescription2:
http://github.com/phuang/ibus/commit/571ee3a071a2ab06aaf757c39827ebb779a8a769

Probably integrating this patch would be no problem but we need to consider if we use ibus_engine_desc_new2()
Comment 4 Fedora Admin XMLRPC Client 2010-08-02 02:17:33 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 fujiwara 2010-09-16 05:34:30 EDT
(In reply to comment #3)
> Hmm.., new EngineDescription2:
> http://github.com/phuang/ibus/commit/571ee3a071a2ab06aaf757c39827ebb779a8a769

Today I noticed I mistook the feature of the patch.
The feature is to enable an engine(likes next engine) but not take on/off the engine.

We may need the similar implementation for trigger keys.

Currently I'm working on variable ibus_engine_desc_new2() with ibus maintainers.
http://github.com/fujiwarat/ibus/commit/ee48085c0e00bf0d7835db1942720ee8495a4fec

Once the implementation is done, we could add any features by engines.
Comment 6 fujiwara 2010-09-16 05:41:57 EDT
(In reply to comment #5)
> The feature is to enable an engine(likes next engine) but not take on/off the
> engine.

s|take on/off|turn on/off|
Comment 7 fujiwara 2011-02-10 02:23:22 EST
*** Bug 674728 has been marked as a duplicate of this bug. ***
Comment 8 Jens Petersen 2011-05-19 01:59:04 EDT
May be good to survey how other distros handle this.

Alternatives might include global hotkey + optional locale based hotkey.
Comment 9 fujiwara 2011-06-03 04:37:14 EDT
Thinking about this again, probably it depends on how the definition of Ctrl+Space we think.

If we think Control + Space to switch prev-next engines, actually almost the implementation would be done while I would see a bug.
However we will need the another definition table of the keyboard hotkeys besides ibus engines. E.g. assign Zenkaku_Hankaku on jp keyboard as one hotkey.

If we think Control + Space to switch on-off engines, probably we need a new implementation in IBusEngineDesc.
Comment 10 fujiwara 2011-09-01 05:53:24 EDT
The new Control + Space is integrated in f16.

Note You need to log in before you can comment on or make changes to this bug.