Bug 509485 - commit_first_segment feature doesn't work
commit_first_segment feature doesn't work
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus-anthy (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
: 509486 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-02 22:59 EDT by Akira TAGOH
Modified: 2009-08-28 18:01 EDT (History)
5 users (show)

See Also:
Fixed In Version: 1.1.0.20090814-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-28 18:01:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for engine/engine.py (1.89 KB, patch)
2009-08-11 02:11 EDT, fujiwara
no flags Details | Diff
Patch for engine/engine.py (2.27 KB, patch)
2009-08-12 01:37 EDT, fujiwara
no flags Details | Diff

  None (edit)
Description Akira TAGOH 2009-07-02 22:59:51 EDT
Description of problem:
As per ibus-anthy config UI, commit_first_segment shortcut key are assigned to Shift+Down though, even if pressing Shift+Down during conversion, nothing happens.

Version-Release number of selected component (if applicable):
ibus-1.1.0.20090612-1.fc11
ibus-anthy-1.1.0.20090603-1.fc11

How reproducible:
always

Steps to Reproduce:
1.turn on IM
2.type nihongonobenkyou and press space
3.press shift+down
  
Actual results:
nothing happens. the candidate word at the first segment still is in the preedit

Expected results:
should be committed.

Additional info:
Comment 1 Jens Petersen 2009-07-28 05:31:09 EDT
also true for ibus-anthy-1.2.0.20090617-1.fc12
Comment 2 fujiwara 2009-08-11 01:58:07 EDT
I could reproduce this bug on trunk.
Comment 3 fujiwara 2009-08-11 02:11:53 EDT
Created attachment 356978 [details]
Patch for engine/engine.py

Implemented commit_first_segment function.

1. Commit the first segment.
2. Remove the first segment in preedit.
3. Remove the segment element.
4. Update lookup string.

There are several regression tests.

test case 1:
2 segments
space, shift + down arrow, space, enter

test case 2:
2 segment
space, shift + down arrow, backspace, space, enter

test case 3:
2 segment
space, shift + down arrow, shift + down arrow

test case 4:
3 segment
space, shift + down, shift + down, shift + down

test case 5:
3 segment
space, shift + down, space, enter

test case 6:
3 segment
space, shift + down, shift + down, space, enter

test case 7:
3 segment
right arrow, space, shift + down, shift + down, shift + down

test case 8:
3 segment
right arrow, right arrow, space, shift + down, shift + down, shift + down
Comment 4 fujiwara 2009-08-12 01:35:12 EDT
*** Bug 509486 has been marked as a duplicate of this bug. ***
Comment 5 fujiwara 2009-08-12 01:37:57 EDT
Created attachment 357115 [details]
Patch for engine/engine.py

Updated the patch for bug 509486.
Comment 6 fujiwara 2009-08-13 05:17:03 EDT
It seems now is alpha freeze but the build is finised.
http://koji.fedoraproject.org/koji/taskinfo?taskID=1602834
Comment 8 Fedora Update System 2009-08-14 02:01:59 EDT
ibus-anthy-1.1.0.20090814-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/ibus-anthy-1.1.0.20090814-1.fc11
Comment 9 Fedora Update System 2009-08-15 04:23:51 EDT
ibus-anthy-1.1.0.20090814-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ibus-anthy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8610
Comment 10 Fedora Update System 2009-08-28 18:00:52 EDT
ibus-anthy-1.1.0.20090814-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.