This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 509532 - Move /usr/bin/qemu-kvm into the qemu-kvm package
Move /usr/bin/qemu-kvm into the qemu-kvm package
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Fedora Extras Quality Assurance
:
: 518718 (view as bug list)
Depends On:
Blocks: F12VirtTarget
  Show dependency treegraph
 
Reported: 2009-07-03 06:46 EDT by Mark McLoughlin
Modified: 2009-09-14 11:25 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-14 10:58:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2009-07-03 06:46:51 EDT
There's no reason for qemu-kvm to be a completely empty package, it makes perfect sense for it to contain /usr/bin/qemu-kvm.

It should still require qemu-system-x86 for the BIOS symlinks
Comment 3 Mark McLoughlin 2009-09-04 03:46:25 EDT
*** Bug 518718 has been marked as a duplicate of this bug. ***
Comment 4 Mark McLoughlin 2009-09-14 10:17:39 EDT
Okay, what I'm going to do is move /usr/bin/qemu-kvm, kvm.modules and 80-kvm.rules into the qemu-kvm package

The %post scriptlet to run kvm.modules and the kvm Provides/Obsoletes will also be moved

The obvious concern is that if people only have qemu-system-x86 installed and update, they lose /usr/bin/qemu-kvm

However, since we've always had qemu-kvm in comps, I expect it will only affect a small number of people and I think it's okay to make this change.

Also, note that the likes of libguestfs explicitly requires qemu-kvm, rather than qemu-system-x86
Comment 5 Mark McLoughlin 2009-09-14 10:58:13 EDT
danpb gives a good reason to not do this, basically that the qemu-kvm sub-package will go away eventually when we start using stock upstream qemu instead of the qemu-kvm fork

http://www.redhat.com/archives/fedora-virt/2009-September/msg00045.html

If it wasn't for the fact that comps won't pull in qemu-system-x86 if we just have Provides: qemu-kvm, we wouldn't have this sub-package at all

Also, qemu-kvm is properly merged upstream, we might re-name this sub-package to qemu-system, meaning "the appropriate qemu-system-* package for this architecture"

Note You need to log in before you can comment on or make changes to this bug.