Bug 509703 - Using GIMP to pixel-edit causes X server to abnormally exit
Using GIMP to pixel-edit causes X server to abnormally exit
Status: CLOSED DUPLICATE of bug 504300
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-05 06:02 EDT by Alex Butcher
Modified: 2009-07-05 17:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-05 17:40:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Butcher 2009-07-05 06:02:05 EDT
Description of problem:

Using GIMP to pixel-edit an image causes the X server to catch a signal 11 and exit back to gdm.

Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-1.fc11
gimp-2.6.6-3.fc11

How reproducible:


Steps to Reproduce:
1. Open an image in GIMP
2. Magnify to 1600%, select the 1x1 pixel brush
3. Click somewhere in the image to set that pixel
  
Actual results:

Get kicked out of X session back to gdm login prompt

Expected results:

Able to use any X application without it crashing the X server.

Additional info:

Using xorg-x11-drv-nvidia-185.18.14-2.fc11 driver with a Geforce 7600GT card.
Comment 1 Alex Butcher 2009-07-05 06:31:59 EDT
Actually, just using GIMP to edit an image at all causes the X server to crash; no magnification nor 1x1 pixel brush necessary; e.g. using the 'Fill' tool has the same effect.
Comment 2 Alex Butcher 2009-07-05 06:36:25 EDT
Regression of Bug 489776 ?
Comment 3 Alex Butcher 2009-07-05 06:37:46 EDT
Backtrace:
0: /usr/bin/Xorg(xorg_backtrace+0x26) [0x4e89b6]
1: /usr/bin/Xorg(xf86SigHandler+0x6f) [0x47d63f]
2: /lib64/libc.so.6 [0x3f5bc33370]

Fatal server error:
Caught signal 11.  Server aborting
Comment 4 Alex Butcher 2009-07-05 17:37:14 EDT
Disabling the vnc Module in xorg.conf appears to have fixed it, as per bug 504300
Comment 5 Alex Butcher 2009-07-05 17:40:54 EDT

*** This bug has been marked as a duplicate of bug 504300 ***

Note You need to log in before you can comment on or make changes to this bug.