Bug 50986 - Installer crashes with TypeError
Installer crashes with TypeError
Status: CLOSED DUPLICATE of bug 50791
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-08-05 23:54 EDT by Need Real Name
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-08-06 00:57:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-05 23:54:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010801

Description of problem:
Error ocurrs on the post installation phase after a default Workstation
install on expert mode.

How reproducible:

Steps to Reproduce:
- expert install
- Workstation install


Actual Results:  

Additional info:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 608, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/gui.py", line 348, in run
    self.icw.run (self.runres, configFileData)
  File "/usr/lib/anaconda/gui.py", line 776, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2608, in mainloop
  File "/usr/lib/anaconda/gui.py", line 495, in handleRenderCallback
  File "/usr/lib/anaconda/iw/progress_gui.py", line 122, in renderCallback
  File "/usr/lib/anaconda/gui.py", line 397, in nextClicked
  File "/usr/lib/anaconda/dispatch.py", line 139, in gotoNext
  File "/usr/lib/anaconda/dispatch.py", line 204, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/bootloader.py", line 658, in writeBootloader
  File "/usr/lib/anaconda/bootloader.py", line 540, in write
    justConfig | (self.useGrubVal))
  File "/usr/lib/anaconda/bootloader.py", line 523, in writeLilo
    kernelList, chainList, defaultDev)
  File "/usr/lib/anaconda/bootloader.py", line 498, in getBootloaderConfig
    config.addEntry("boot", '/dev/' + liloTarget, replace = 0)
TypeError: illegal argument type for built-in operation
Comment 1 Matt Wilson 2001-08-06 00:57:18 EDT
There should be more information if you saved this to a floppy.  Did it get cut
Comment 2 Jeremy Katz 2001-08-06 01:10:14 EDT
No need for the extra bits... a fix for this got committed to CVS yesterday

*** This bug has been marked as a duplicate of 50791 ***

Note You need to log in before you can comment on or make changes to this bug.