Bug 509946 - When use "Undo" can not let you back to the previous state in "Show All History" window
When use "Undo" can not let you back to the previous state in "Show All Histo...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
: 510661 (view as bug list)
Depends On:
Blocks: 510661
  Show dependency treegraph
 
Reported: 2009-07-06 23:04 EDT by Yewei Shao
Modified: 2009-07-20 09:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 510661 (view as bug list)
Environment:
Last Closed: 2009-07-20 09:56:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 505230 None None None Never

  None (edit)
Description Yewei Shao 2009-07-06 23:04:06 EDT
Description of problem:
When go the the "History -> Show All History", and in "show all history" window, the function of "Undo" under the "Organize" in the menubar does not work correctly.

Version-Release number of selected component (if applicable):
firefox-3.5.1

How reproducible: everytime


Steps to Reproduce:
1. In firefox menubar, go to "History -> Show All History"
2. In pop out window, double click "All Bookmarks" in the left window, and then choose a bookmark folder and choose a bookmark in it.
3. Go to "Organize -> Cut" and then choose another bookmark folder, then click "Organize -> Paste"
4. Go to "Organize -> Undo"
  
Actual results:
After the step 4, the bookmark will be removed from the new folder but not moved to original folder.

Expected results:
After the step 3, the bookmark should be moved from one bookmark folder to another folder.
After the step 4, the bookmark should be moved back to the original folder and should disappeared from the second folder.

Additional info:
Comment 1 Matěj Cepl 2009-07-20 09:48:36 EDT
*** Bug 510661 has been marked as a duplicate of this bug. ***
Comment 2 Matěj Cepl 2009-07-20 09:56:13 EDT
We filed this bug in the upstream database (https://bugzilla.mozilla.org/show_bug.cgi?id=505230) and believe that it is more appropriate to let it be resolved upstream.

We will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.

Note You need to log in before you can comment on or make changes to this bug.