Bug 510661 - When use "Undo" can not let you back to the previous state in "Show All History" window
When use "Undo" can not let you back to the previous state in "Show All Histo...
Status: CLOSED DUPLICATE of bug 509946
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: firefox (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Gecko Maintainer
desktop-bugs@redhat.com
:
Depends On: 509946
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-10 01:24 EDT by Rita Wu
Modified: 2013-07-02 21:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 509946
Environment:
Last Closed: 2009-07-20 09:48:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rita Wu 2009-07-10 01:24:03 EDT
+++ This bug was initially created as a clone of Bug #509946 +++

Description of problem:
When go the the "History -> Show All History", and in "show all history" window, the function of "Undo" under the "Organize" in the menubar does not work correctly.

Version-Release number of selected component (if applicable):
firefox-3.5.1

How reproducible: everytime


Steps to Reproduce:
1. In firefox menubar, go to "History -> Show All History"
2. In pop out window, double click "All Bookmarks" in the left window, and then choose a bookmark folder and choose a bookmark in it.
3. Go to "Organize -> Cut" and then choose another bookmark folder, then click "Organize -> Paste"
4. Go to "Organize -> Undo"
  
Actual results:
After the step 4, the bookmark will be removed from the new folder but not moved to original folder.

Expected results:
After the step 3, the bookmark should be moved from one bookmark folder to another folder.
After the step 4, the bookmark should be moved back to the original folder and should disappeared from the second folder.

Additional info:
Comment 1 Rita Wu 2009-07-10 01:27:05 EDT
This bug can also occurs in Bookmark->Organize Bookmarks. It seems they are the same window.
Comment 2 Matěj Cepl 2009-07-20 09:48:36 EDT
Please, don't do unnecessary clones of Rawhide bugs. We do keep Firefox in sync, plus most of our patches go upstream as well.

*** This bug has been marked as a duplicate of bug 509946 ***

Note You need to log in before you can comment on or make changes to this bug.