Bug 509964 - Bind utils produce error while loading shared libraries
Bind utils produce error while loading shared libraries
Status: CLOSED DUPLICATE of bug 509635
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
11
All Linux
low Severity urgent
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-07 03:35 EDT by Panos Kavalagios
Modified: 2013-04-30 19:43 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-13 07:10:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Panos Kavalagios 2009-07-07 03:35:30 EDT
Description of problem: Error while loading liblwres.so.50


Version-Release number of selected component (if applicable): bind-libs-9.6.1-2.fc11.x86_64


How reproducible: Just run whatever bind util like "host" and "nslookup"


Steps to Reproduce:
1. Run host www.cnn.com
2.
3.
  
Actual results:
host www.cnn.com
host: error while loading shared libraries: liblwres.so.50: cannot open shared object file: No such file or directory


Expected results: IP resolving of www.cnn.com


Additional info: The link of shared library is broken:
ls -al /usr/lib64/liblwres*
lrwxrwxrwx 1 root root    18 2009-07-06 08:55 /usr/lib64/liblwres.so.50 -> liblwres.so.50.2.0
-rwxr-xr-x 1 root root 73336 2009-06-24 17:58 /usr/lib64/liblwres.so.50.0.2
It should have pointed to liblwres.so.50.0.2 and not to liblwres.so.50.2.0. A workaround would be possibly to manually fix the link.
Comment 1 Jon Baker 2009-07-07 10:05:22 EDT
Manually fixing the link does indeed correct the problem.  There is a second one that needs fixing, libbind9.so.50 -> libbind9.so.50.2.0 should be libbind9.so.50 -> libbind9.so.50.0.3

This appears to have been changed on my system with the latest updates of the bind packages.
Comment 2 Jon Baker 2009-07-07 10:23:27 EDT
Also, appears (for me) to only be effecting the 64-bit libraries, as my i386 box has the correct file that the link is linking to.
Comment 3 Stephen John Smoogen 2009-07-07 16:56:01 EDT
running ldconfig -v fixed both problems.
Comment 4 Panos Kavalagios 2009-07-08 00:55:56 EDT
Indeed, ldconfig can also help as an alternative workaround and only as that. The link was delivered by the bind-libs package:

$ rpm -qf /usr/lib64/liblwres.so.50
bind-libs-9.6.1-2.fc11.x86_64

Either the package to include the correct link or to run ldconfig as post install procedure. In no case a user should be required to run additional programs or manually fix broken links.
Comment 5 Adam Miller 2009-07-09 11:42:36 EDT
[10:40:25][adam@turnip][SRPMS]+ host www.google.com
host: error while loading shared libraries: liblwres.so.50: cannot open shared object file: No such file or directory
[10:41:03][adam@turnip][SRPMS]+ rpm -qf /usr/lib/liblwres.so.50
bind-libs-9.6.1-2.fc11.i586
[10:41:17][adam@turnip][SRPMS]+ uname -a
Linux fooBox 2.6.29.5-191.fc11.i686.PAE #1 SMP Tue Jun 16 23:19:53 EDT 2009 i686 i686 i386 GNU/Linux


Happening on 32-bit here.
Comment 6 Stephen Cuppett 2009-07-12 14:07:22 EDT
Potential duplicate of Bug #509618.
Comment 7 Adam Tkac 2009-07-13 07:10:26 EDT

*** This bug has been marked as a duplicate of bug 509635 ***

Note You need to log in before you can comment on or make changes to this bug.