Bug 509635 - bind failed to start, because of wrong linked libs
bind failed to start, because of wrong linked libs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
: 509618 509649 509964 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-04 06:40 EDT by Stefan Jensen
Modified: 2013-04-30 19:43 EDT (History)
17 users (show)

See Also:
Fixed In Version: 9.6.1-3.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 17:56:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpm transaction log (21.53 KB, text/plain)
2009-07-04 12:22 EDT, Mamoru TASAKA
no flags Details
rpm transaction log (22.08 KB, text/plain)
2009-07-13 11:25 EDT, Mamoru TASAKA
no flags Details

  None (edit)
Description Stefan Jensen 2009-07-04 06:40:46 EDT
Description of problem:

Bind failed to start because of wrong linked libs.

Version-Release number of selected component (if applicable):

bind-libs-9.6.1-2.fc11.x86_64
bind-9.6.1-2.fc11.x86_64
bind-chroot-9.6.1-2.fc11.x86_64
bind-utils-9.6.1-2.fc11.x86_64

How reproducible:

Always

Steps to Reproduce:

1. install latest bind
2. service named start

  
Actual results:

/usr/sbin/named: error while loading shared libraries: libbind.so.50: cannot open shared object file: No such file or directory

Expected results:

Bind start and working.

Additional info:

It seems, that the latest update is linked to the wrong libs, that are not in the repo:

/usr/lib64/libbind9.so.50 -> libbind9.so.50.2.0
/usr/lib64/libbind9.so.50.0.3

/usr/lib64/liblwres.so.50 -> liblwres.so.50.2.0
/usr/lib64/liblwres.so.50.0.2


I corrected the links to:

libbind9.so.50 -> libbind9.so.50.0.3
liblwres.so.50 -> liblwres.so.50.0.2

and bind semms to work ok.

best regards
Comment 1 Matt Castelein 2009-07-04 10:27:19 EDT
*** Bug 509649 has been marked as a duplicate of this bug. ***
Comment 2 Mamoru TASAKA 2009-07-04 12:22:24 EDT
Created attachment 350497 [details]
rpm transaction log

Easily reprocible as attached.

The reason this happened is
- bind-libs-9.6.1-0.4.rc1.fc11 had libbind9.so.50.2.0,
  bind-libs-9.6.1-2.fc11 has libbind9.so.50.0.3,
  which is the less version than libbind9.so.50.2.0
- rpm usually skips "%postun ldconfig" on upgrade like this case.

So when bind is upgrade from 9.6.1-0.4.rc1.fc11 to :
- First libbind9.so.50 pointed to libbind9.so.50.2.0
- 9.6.1-2.fc11 binary rpm is unpacked, at this stage libbind9.so.50
  pointed to libbind9.so.50.0.3
- ldconfig is called in %post 9.6.1-2.fc11. Now libbind9.so.50
  points to libbind9.so.50.2.0 because this one has higher version.
- Then 9.6.1-0.4.rc1.fc11 is removed, now libbind9.so.50 symlink
  is broken because libbind9.so.50.2.0 does not exist any longer.
- And ldconfig in %postun 9.6.1-0.4.rc1.fc11 is skipped (as the attached
  log shows). Broken symlink is not touched.
Comment 3 Nadav Har'El 2009-07-05 03:38:03 EDT
The broken symlinks also break nslookup:

$ nslookup                       
nslookup: error while loading shared libraries: liblwres.so.50: cannot open shared object file: No such file or directory

/usr/lib64/liblwres.so.50 is a broken symlink to liblwres.so.50.2.0, while the version that actually exists is liblwres.so.50.0.2
Comment 4 Michael Hampton 2009-07-06 16:40:18 EDT
This looks like a duplicate of bug 509618.

Running ldconfig manually resolved the issue for me.
Comment 5 Adam Tkac 2009-07-13 07:10:26 EDT
*** Bug 509964 has been marked as a duplicate of this bug. ***
Comment 6 Adam Tkac 2009-07-13 07:10:31 EDT
*** Bug 509618 has been marked as a duplicate of this bug. ***
Comment 7 Adam Tkac 2009-07-13 09:12:35 EDT
Thanks for report, fixed in bind-9.6.1-3.fc11.
Comment 8 Fedora Update System 2009-07-13 09:16:16 EDT
bind-9.6.1-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/bind-9.6.1-3.fc11
Comment 9 Mamoru TASAKA 2009-07-13 11:25:11 EDT
Created attachment 351484 [details]
rpm transaction log

Seems to work, thanks.
Comment 10 Scott Robbins 2009-07-14 20:40:52 EDT
Seems as if it may be necessary for bind-utils as well.  On a workstation, without bind installed, updated today, bind-utils is still showing as bind-9.6.1-2.fc11 and giving the same error, with, for example host <ipaddress>. 

The fix of running ldconfig works.
Comment 11 Panos Kavalagios 2009-07-15 01:52:19 EDT
Indeed, I don't have the bind package installed either:

$ rpm -qa | grep "^bind"
bind-utils-9.6.1-2.fc11.x86_64
bind-libs-9.6.1-2.fc11.x86_64

However, the problem was resolved from a recently update that issued possibly ldconfig.
Comment 12 Robert Scheck 2009-07-15 02:54:16 EDT
Every call of "ldconfig" should solve this problem, nevertheless, the bind
package should execute ldconfig in %post etc.
Comment 13 Adam Tkac 2009-07-15 03:36:59 EDT
reply to comment #10 and comment #11:

Fixed package (bind-9.6.1-3.fc11) is still in "pending" state so it is not available in the official repositories. When fixed package hits stable or testing repo you will be notified. Please be patient.
Comment 14 Fedora Update System 2009-07-19 06:09:18 EDT
bind-9.6.1-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bind'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7708
Comment 15 Panos Kavalagios 2009-07-20 02:10:50 EDT
Adam,

I apologise for the inconvenience. It seems that we haven't made our point clear.

# yum --enablerepo=updates-testing update bind
<snip>
Setting up Update Process
Package(s) bind available, but not installed.
No Packages marked for Update

This is what we were trying to say on comment 10 and comment 11. I don't know how a package that it is not installed on my system will resolve my issue through the update process. It may resolve the current problem reported on this bug when bind package is installed, but not for the duplicate bugs where a simple usage of bind-utils is concerned.
Comment 16 Robert Scheck 2009-07-20 02:53:39 EDT
http://cvs.fedoraproject.org/viewvc/rpms/bind/F-11/bind.spec?r1=1.317&r2=1.318

Panos, the fix was applied to bind-libs, so:

  yum --enablerepo=updates-testing update bind-libs

IIRC neither bind nor bind-utils contain libraries so must not contain ldconfig
calls, but bind-libs.
Comment 17 Fedora Update System 2009-07-22 17:56:35 EDT
bind-9.6.1-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.