Bug 510010 - Java perspective gone from Eclipse
Java perspective gone from Eclipse
Status: CLOSED DUPLICATE of bug 509616
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-07 08:11 EDT by Nadav Har'El
Modified: 2009-07-20 03:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-20 03:39:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nadav Har'El 2009-07-07 08:11:53 EDT
After upgrading from Fedora 10 to 11, Eclipse suddenly "forgot" all about Java development. It doesn't edit Java files (and rather opens Emacs!), it doesn't compile Java, and the "Java perspective" is missing from the "Open Perspective menu".

Needless to see, I still have the eclipse-jdt package, like I always had.

Trying to look if other people faced this problem before, I found these posts:
http://forums.fedoraforum.org/showthread.php?p=1229483
http://forums.fedoraforum.org/showthread.php?p=1238142

Things started working again only after I removed my ~/.eclipse directory. I don't know what was specifically wrong in this directory - it's a shame I had to remove it all (because it also removed some of my settings), but I can send someone a copy of this directory before I deleted it, if you're interested.
Comment 1 Eric Floehr 2009-07-07 09:21:37 EDT
I am experiencing the same issue, though I've had Fedora 11 since the start.

Eclipse Java worked fine until I updated on July 3:

Jul 03 14:41:16 Updated: 1:eclipse-swt-3.4.2-11.fc11.x86_64
Jul 03 14:41:17 Updated: 1:eclipse-rcp-3.4.2-11.fc11.x86_64
Jul 03 14:41:27 Updated: 1:eclipse-platform-3.4.2-11.fc11.x86_64
Jul 03 14:42:27 Updated: 1:eclipse-jdt-3.4.2-11.fc11.x86_64
Jul 03 14:42:33 Updated: 1:eclipse-pde-3.4.2-11.fc11.x86_64


Previously, I had been using the -9 builds of these packages successfully.  It seems something in the -11 build broken Java editing...no Java perspective, no Java options, etc.
Comment 2 Eric Floehr 2009-07-07 09:31:10 EDT
Downgrading to the -9 builds restores Java and svn functionality, so it's definitely something in the -11 build:

yum downgrade eclipse-swt eclipse-rcp eclipse-platform eclipse-jdt eclipse-pde
Comment 3 Nadav Har'El 2009-07-07 10:03:37 EDT
This is probably the same bug as the one reported in bug 509616
Comment 4 Andrew Overholt 2009-07-07 10:35:34 EDT
Yeah, this bug is very unfortunate but we are focusing on getting the 3.5 series ready which is no longer affected by this bug.  Basically, we try to avoid updates :(  Sorry we had one in this case and that you were affected by it.
Comment 5 Eric Floehr 2009-07-07 10:51:28 EDT
Thankfully running "eclipse -clean" solves the problem, as noted in bug 509616.  Thanks.
Comment 6 Alexander Kurtakov 2009-07-20 03:39:38 EDT

*** This bug has been marked as a duplicate of bug 509616 ***

Note You need to log in before you can comment on or make changes to this bug.