Bug 51012 - msiing dhared libraries. Files in wrong places
msiing dhared libraries. Files in wrong places
Status: CLOSED CURRENTRELEASE
Product: Red Hat Powertools
Classification: Retired
Component: mpich (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-06 11:12 EDT by Cormack, Justin
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-06 11:15:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example spec file (needs some updating) (6.46 KB, text/plain)
2001-08-06 11:14 EDT, Cormack, Justin
no flags Details

  None (edit)
Description Cormack, Justin 2001-08-06 11:12:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.73 [en] (X11; U; Linux 2.4.4 i586)

Description of problem:
The shared libraries (libmpich.so*) are missing. There is a build flag to
enable them.

All the files are in very odd places: all under /usr/lib/mpich instead of
standard install places (and some of the docs are not under
/usr/share/doc). The man pages are also in /usr/lib/mpich/man. Could
everything be moved to standard places???

I attach an old spec file from when I maintained this package under
contrib|net. It probably needs some fixing up but it did attempt to put
things in the right places, build all the parts, and provide ssh rather
than rsh transport for mpich.



How reproducible:
Always

Steps to Reproduce:
1. Try to build program that needs shared mpich library
2. Try to build program that expects to find libraries and header files in
usual places
3. er, thats it.
	

Additional info:
Comment 1 Cormack, Justin 2001-08-06 11:14:56 EDT
Created attachment 26433 [details]
example spec file (needs some updating)
Comment 2 Trond Eivind Glomsrxd 2001-08-06 11:17:21 EDT
The shared libraries aren't missing, they aren't built.

As for the file locations, the reasons are:

1) It's where mpich wants to put them 
2) /usr/doc isn't used, it's /usr/share/doc for all apps now
3) The primary MPI package is lam, and not changing the mpich package's default
path is necesarry to avoid collisions
Comment 3 Ed Avis 2001-10-18 08:06:44 EDT
Since this bug is closed, I've filed an RFE for building the .so files: bug 54768.

Note You need to log in before you can comment on or make changes to this bug.