This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 510135 - Cluster install openais dependency
Cluster install openais dependency
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: distribution (Show other bugs)
1.1.2
All Linux
medium Severity high
: 1.2
: ---
Assigned To: Mike Cressman
ppecka
: FutureFeature
Depends On:
Blocks: 527551
  Show dependency treegraph
 
Reported: 2009-07-07 16:15 EDT by William Henry
Modified: 2009-12-03 04:19 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Messaging enhancement A dependency was added to the <filename>qpid-cluster</filename> package. Clustering on &RHM; requires <filename>openais-0.80.3-22.el5_3.10</filename> and <filename>cman-2.0.98-1.el5_3.8</filename> or better.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-03 04:19:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Henry 2009-07-07 16:15:35 EDT
Description of problem:

We currently don't check for any openais version dependency. Nor do we install the right version of openais with the MRG Messaging install.

As a result it is possible to successfully install MRG Messaging Cluster without the right version of openais.  If an unsupported version of openais is installed this has resulted in a crash of the cluster with the symptom of complaining about Framing errors. See (not a bug) BZ:
https://bugzilla.redhat.com/show_bug.cgi?id=506293 

How reproducible:

Install MRG Messaging with Cluster with openais-0.80.3-22.el5 installed.
Configure cluster as per documentation.
Bring up cluster and start sending messages. It will eventually crash - both brokers will go down together.

Installing openais-0.80.3-22.el5_3.4 fixes the problem. 


Expected results:
We should either:
1. Install openais with MRG Messaging Cluster install.
or 
2. Check that we have at least the lowest supported version of openais installed. IF an unsupported version is installed we either:
a. Fail
b. Prompt to update to latest supported version. 

Additional info:
Bug describing what you can expect if wrong version is installed:
https://bugzilla.redhat.com/show_bug.cgi?id=506293
Comment 1 Carl Trieloff 2009-07-07 16:53:23 EDT
I believe we would want to allow the last two versions of AIS in RHN for 5.3 or later versions to be valid for the MRG update.

We need to lookup what that version would be, so we don't force updates when they are not strictly required in all cases.
Comment 2 Nuno Santos 2009-07-21 15:38:51 EDT
As per aconway and jneedle, 1.1.6 was tested with openais-0.80.3-22.el5_3.8,
but .el_3.4 also works.
Comment 3 Mike Cressman 2009-10-21 14:00:10 EDT
Added install dependencies for qpid-cluster package, openais >= openais-0.80.3-22.el5_3.10, cman >= cman-2.0.98-1.el5_3.8
Comment 5 Irina Boverman 2009-10-29 10:28:13 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
Added install dependencies for qpid-cluster package, openais >=openais-0.80.3-22.el5_3.10, cman >= cman-2.0.98-1.el5_3.8  (510135)
Comment 6 Lana Brindley 2009-11-03 21:32:26 EST
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1,3 @@
+Messaging bug fix
+
 Added install dependencies for qpid-cluster package, openais >=openais-0.80.3-22.el5_3.10, cman >= cman-2.0.98-1.el5_3.8  (510135)
Comment 7 Lana Brindley 2009-11-03 21:40:39 EST
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1,3 +1,9 @@
 Messaging bug fix
 
-Added install dependencies for qpid-cluster package, openais >=openais-0.80.3-22.el5_3.10, cman >= cman-2.0.98-1.el5_3.8  (510135)+Added install dependencies for qpid-cluster package, openais >=openais-0.80.3-22.el5_3.10, cman >= cman-2.0.98-1.el5_3.8  (510135)
+
+--
+
+A dependency was added to the <filename>qpid-cluster</filename> package. Clustering on &RHM; requires <filename>openais-0.80.3-22.el5_3.10</filename> and <filename>cman-2.0.98-1.el5_3.8</filename> or better.
+
+--
Comment 8 Lana Brindley 2009-11-03 21:43:32 EST
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1,9 +1,3 @@
 Messaging bug fix
 
-Added install dependencies for qpid-cluster package, openais >=openais-0.80.3-22.el5_3.10, cman >= cman-2.0.98-1.el5_3.8  (510135)
+A dependency was added to the <filename>qpid-cluster</filename> package. Clustering on &RHM; requires <filename>openais-0.80.3-22.el5_3.10</filename> and <filename>cman-2.0.98-1.el5_3.8</filename> or better.-
---
-
-A dependency was added to the <filename>qpid-cluster</filename> package. Clustering on &RHM; requires <filename>openais-0.80.3-22.el5_3.10</filename> and <filename>cman-2.0.98-1.el5_3.8</filename> or better.
-
---
Comment 9 ppecka 2009-11-06 07:05:22 EST
The issue has been fixed, validated on RHEL 5.4 i386 / x86_64 on
packages:

#rpm -qa | grep -E 'openais|cman|qpid' | sort -u
cman-2.0.115-1.el5
openais-0.80.6-8.el5

python-qpid-0.5.752581-4.el5
qpidc-0.5.752581-31.el5
qpidc-devel-0.5.752581-31.el5
qpidc-rdma-0.5.752581-31.el5
qpidc-ssl-0.5.752581-31.el5
qpidd-0.5.752581-31.el5
qpidd-acl-0.5.752581-31.el5
qpidd-cluster-0.5.752581-31.el5
qpidd-devel-0.5.752581-31.el5
qpid-dotnet-0.4.738274-2.el5
qpidd-rdma-0.5.752581-31.el5
qpidd-ssl-0.5.752581-31.el5
qpidd-xml-0.5.752581-31.el5
qpid-java-client-0.5.751061-9.el5
qpid-java-common-0.5.751061-9.el5

-> VERIFIED
Comment 10 Lana Brindley 2009-11-26 21:21:13 EST
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1,3 +1,3 @@
-Messaging bug fix
+Messaging enhancement
 
 A dependency was added to the <filename>qpid-cluster</filename> package. Clustering on &RHM; requires <filename>openais-0.80.3-22.el5_3.10</filename> and <filename>cman-2.0.98-1.el5_3.8</filename> or better.
Comment 12 errata-xmlrpc 2009-12-03 04:19:01 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1633.html

Note You need to log in before you can comment on or make changes to this bug.