Bug 51036 - Syntax error in shell script causes useless log
Syntax error in shell script causes useless log
Status: CLOSED DUPLICATE of bug 41830
Product: Red Hat Linux
Classification: Retired
Component: hotplug (Show other bugs)
7.1
All Linux
medium Severity low
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-06 15:40 EDT by Darin Nelson
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-06 15:40:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darin Nelson 2001-08-06 15:40:38 EDT
An extraneuos ampersand on an 'exec' line (55 or so) of the
/etc/hotplug/net.agent script causes bad error message.

How reproducible:
Always

Steps to Reproduce:
1. Insert a pcmcia network card into a redhat 7.1 laptop

	

Actual Results:  Look at the system messages (/var/log/messages).  The line:
"Date hostname /etc/hotplug/net.agent: register event not handled"
is issued.  This is not true.  An added ampersand on line 55 of the script
for the default exec case causes thread to return.  Mesg is generated.  The
script does its job, but the error is issued (erroneously).


Expected Results:  No error.

Additional info:  If you remove the '&' all is good.
Comment 1 Trond Eivind Glomsrxd 2001-08-06 17:39:37 EDT

*** This bug has been marked as a duplicate of 41830 ***

Note You need to log in before you can comment on or make changes to this bug.