Bug 510485 - general protection fault - radeon_read_ring_rptr
general protection fault - radeon_read_ring_rptr
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 510482 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-09 08:56 EDT by Nivag
Modified: 2010-03-31 10:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-31 06:58:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
segment of log (5.40 KB, text/plain)
2009-07-09 08:56 EDT, Nivag
no flags Details
segment of messages log (5.45 KB, text/plain)
2009-07-11 01:04 EDT, Nivag
no flags Details

  None (edit)
Description Nivag 2009-07-09 08:56:27 EDT
Created attachment 351067 [details]
segment of log

Description of problem:
crash
details from log

Version-Release number of selected component (if applicable):
2.6.29.5-191.fc11.x86_64

How reproducible:
?

Steps to Reproduce:
1.?
2.
3.
  
Actual results:
crash

Expected results:
no crash

Additional info:
up to date Fedora 11 install
AMD 810 quad core 64 bit
8 GB DDR3 RAM
5 * 500GB in software RAID-6 configuration
ASUS M4A78T-E mother board
Comment 1 Nivag 2009-07-11 01:04:11 EDT
Created attachment 351328 [details]
segment of messages log

'jupiter': problem host
'neptune': my main workstation

I found that the screen had frozen on saturn, but the logged in terminal from jupiter was still active.

From jupiter, I had top displaying tasks from saturn.  I attempted to kill xorg which was at about 100% processor usage using the default signal, no affect.  Then I used signal 9, and got kernel messages on all my terminals logged into saturn (xorg cpu usage now about 0%).  Found the relevant section of the log and attached it.Linux saturn 

kernel:
2.6.29.5-191.fc11.x86_64.debug #1 SMP Tue Jun 16 23:09:06 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
Comment 2 Nivag 2009-07-11 01:27:29 EDT
This may be related to:

Bug 510482 -  unable to handle kernel paging request - radeon_read_ring_rptr
Comment 3 Nivag 2009-07-11 01:37:42 EDT
I note that the first 6 lines, at least, of the call trace appear to be identical.
Comment 4 Nivag 2009-07-27 12:46:11 EDT
I think this is a duplicate of  Bug 488940
Comment 5 Jérôme Glisse 2009-10-14 06:50:41 EDT
Can you test with fedora 12 livecd and report if it works with it.
Comment 6 Nivag 2009-10-31 05:40:21 EDT
Sorry I can't, as the live CD fails to load properly see Bug 531945.
Comment 7 Vedran Miletić 2010-03-23 19:44:25 EDT
Can you retest now in F13 Alpha?
Comment 8 Nivag 2010-03-30 21:43:44 EDT
Sorry, it is not practical for me to run the Fedora 13 alpha, as the machine is both my main development machine and the gateway to the Internet for my local network.

I have been running Fedora 12 on saturn for a few months now.

However, I looked through my messages logs for the last few weeks and found no evidence of the 'radeon_read_ring_rptr' problem.

My current kernel is:
Linux saturn 2.6.32.10-90.fc12.x86_64 #1 SMP Tue Mar 23 09:47:08 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux
Comment 9 Vedran Miletić 2010-03-31 06:58:16 EDT
Thanks for letting us know.
Comment 10 Vedran Miletić 2010-03-31 06:59:10 EDT
*** Bug 510482 has been marked as a duplicate of this bug. ***
Comment 11 Nivag 2010-03-31 10:39:53 EDT
I suddenly realized that I still had the SidePort disabled, as per:

https://bugzilla.redhat.com/show_bug.cgi?id=488940#c23

Would it be useful if I tried restoring SidePort?

Note You need to log in before you can comment on or make changes to this bug.