This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 510499 - Volume decreased to 40% of previous value when jumping to new track in rhythmbox
Volume decreased to 40% of previous value when jumping to new track in rhythmbox
Status: CLOSED DUPLICATE of bug 488532
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
: Desktop, Reopened
: 514796 516134 516880 519382 (view as bug list)
Depends On: 501972
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-09 10:22 EDT by John Thacker
Modified: 2014-01-21 01:14 EST (History)
38 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-16 20:47:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Thacker 2009-07-09 10:22:30 EDT
Description of problem:
Each time I start playing a new track, or jump to a new track via Next, Previous, or double-clicking on a track, the rhythmbox volume decreases to 40% of its previous value.  This effect does NOT happen when a track ends and rhythmbox moves to the next track in the playlist automatically, only when a new track is selected.

Version-Release number of selected component (if applicable):
rhythmbox-0.12.2.93-1.fc11.x86_64
pulseaudio-0.9.15-14.fc11.x86_64
gstreamer-0.10.23-2.fc11.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start rhythmbox.
2. Start playing a track.
3. Jump to a new track via Previous, Next, or double-clicking.
4. Repeat step 3.
  
Actual results:
Each time a new track starts, volume decreases to 40% of its previous level. From 100% (Full Volume) to 40%, to 16%, to 6(.4)%, etc.  Selected track does play.

Expected results:
Volume should remain the same.

Additional info:
Fairly similar to bug 488532, but the notes there say that rhythmbox is fine.

Not sure if this is a rhythmbox or pulseaudio issue.

Downgraded to rhythmbox-0.12.1-3.fc11.x86_64 and the issue exists but is much diminished.  Under 0.12.1-3, the volume is reduced to 40% of its initial value upon starting the *first* track after rhythmbox is started, but further jumping around has no effect on volume.
Comment 1 John Thacker 2009-07-09 10:33:25 EDT
Additional update:

This only happens with crossfading off.  With crossfading on, everything works as expected.
Comment 2 Eric Donkersloot 2009-07-09 17:12:49 EDT
Confirmed. I have exactly the same issue using rhythmbox-0.12.2.93-1.fc11.x86_64.
Comment 3 Bastien Nocera 2009-07-10 09:34:45 EDT
This is fixed in 0.12.3.
Comment 4 Fedora Update System 2009-07-10 10:21:29 EDT
rhythmbox-0.12.3-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/rhythmbox-0.12.3-1.fc11
Comment 5 Stephan Klein 2009-07-12 17:24:41 EDT
This update (0.12.3-1) does not solve the problem for me. The volume still gets decreased when I skip to a new track.
Comment 6 Fedora Update System 2009-07-16 03:18:13 EDT
rhythmbox-0.12.3-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rhythmbox'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7638
Comment 7 Stephan Klein 2009-07-16 04:57:33 EDT
As I wrote before, the problem persists with the updated rhythmbox-0.12.3-1.fc11.
Comment 8 sawrub 2009-07-22 09:27:41 EDT
I see problem here even when the rhythmbox switches b/w songs automatically.The sound decreases/increases randomly.So had to change it for every song.

And mostly it happens when i'm AFK. ;-) .Though the priority is low bug, but in situations it's p0 for me, as have to rush to switch off the speakers in case it shoots up.

rhythmbox-0.12.1-3.fc11.i586
pulseaudio-0.9.15-14.fc11.i586
gstreamer-0.10.23-2.fc11.i586
Comment 9 Brian Brock 2009-07-24 16:16:43 EDT
I'm seeing an identical problem, with pulseaudio and xmms.  Skipping tracks drops xmms' volume substantially (42% on xmms' sliding volume scale, in current configuration).  I'm sending xmms output to directly to pulseaudio, not via another sound system.

I'm wondering if the underlying problem is in pulseaudio, rather than rhythmbox.

xmms-1.2.11-5.20071117cvs.fc11.x86_64
pulseaudio-0.9.15-14.fc11.x86_64

libcdread is enabled, I'm using it to import a CD to play.  removing xmms-crossfade did not change the behavior.
Comment 10 Fedora Update System 2009-07-27 17:39:45 EDT
rhythmbox-0.12.3-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Stephan Klein 2009-07-27 17:52:46 EDT
This bug is NOT resolved. Why has the broken update been pushed to stable despite it's negative feedback[1]?
Please reopen this bug.

[1] https://admin.fedoraproject.org/updates/F11/FEDORA-2009-7638
Comment 12 Bastien Nocera 2009-07-27 17:56:51 EDT
(In reply to comment #11)
> This bug is NOT resolved. Why has the broken update been pushed to stable
> despite it's negative feedback[1]?
> Please reopen this bug.
> 
> [1] https://admin.fedoraproject.org/updates/F11/FEDORA-2009-7638  

Because the comments say "it's not any worse" to me. So I'll just reopen the bug instead of casting judgement on the maintainers.
Comment 13 Stephan Klein 2009-07-27 18:00:05 EDT
OK, that's resonable :-)
Comment 14 John Thacker 2009-07-27 21:47:10 EDT
As the original bug report, I'll chime in that I'm still seeing the problem, though instead of a strict 40% each time I'm seeing somewhat different numbers.

Enabling crossfade still is a complete workaround, but we shouldn't have to do it.  Still, that's what I'm doing for now.
Comment 15 Aidan Delaney 2009-07-28 03:57:35 EDT
I've got the same issue with both Totem and Rhytmbox.  However, in my case the volume jumps to a level that makes my ears bleed.  Given that it happens with both Totem and Rhythmbox is this a GStreamer issue?

[balor@ScaryMonster ~]$ rpm -qa | grep gstreamer
gstreamer-tools-0.10.23-2.fc11.i586
gstreamer-devel-0.10.23-2.fc11.i586
gstreamer-python-0.10.15-1.fc11.i586
gstreamer-ffmpeg-0.10.7-2.fc11.1.i586
gstreamer-0.10.23-2.fc11.i586
gstreamer-plugins-flumpegdemux-0.10.15-6.fc11.i586
gstreamer-plugins-base-0.10.23-3.fc11.i586
gstreamer-plugins-bad-0.10.13-3.fc11.i586
totem-gstreamer-2.26.3-1.fc11.i586
gstreamer-plugins-good-0.10.15-3.fc11.i586
gstreamer-plugins-ugly-0.10.12-1.fc11.i586
gstreamer-plugins-base-devel-0.10.23-3.fc11.i586
PackageKit-gstreamer-plugin-0.4.8-2.fc11.i586
[balor@ScaryMonster ~]$ rpm -qa | grep rhythmbox
rhythmbox-0.12.1-3.fc11.i586
Comment 16 sawrub 2009-07-28 12:01:39 EDT
All update to 12.3 went in vain,more over now the issue seems to be more frequent.I have to adjust volume on every song change.

[sawrub@sawrub-xbox ~]$ rpm -qa | grep gstreamer
gstreamer-devel-0.10.23-2.fc11.i586
gstreamer-tools-0.10.23-2.fc11.i586
PackageKit-gstreamer-plugin-0.4.8-2.fc11.i586
gstreamer-ffmpeg-0.10.7-2.fc11.1.i586
gstreamer-plugins-base-0.10.23-3.fc11.i586
gstreamer-python-0.10.15-1.fc11.i586
gstreamer-plugins-good-0.10.15-4.fc11.i586
gstreamer-plugins-good-devel-0.10.15-4.fc11.i586
gstreamer-plugins-base-devel-0.10.23-3.fc11.i586
gstreamer-0.10.23-2.fc11.i586
gstreamer-plugins-ugly-0.10.12-1.fc11.i586
gstreamer-plugins-flumpegdemux-0.10.15-6.fc11.i586
gstreamer-plugins-schroedinger-1.0.7-1.fc11.i586


[sawrub@sawrub-xbox ~]$ rpm -qa | grep rhythmbox
rhythmbox-0.12.3-1.fc11.i586
Comment 17 sawrub 2009-07-28 12:11:30 EDT
Moreover now the sound drops down to ZERO,if i manually select a song to play.
Comment 18 sawrub 2009-07-28 12:13:31 EDT
(In reply to comment #17)
> Moreover now the sound drops down to ZERO,if i manually select a song to play.  

Even selecting the next track by clicking the icon provided for 'Next Track' also results in same.
Comment 19 Bastien Nocera 2009-07-31 07:52:47 EDT
*** Bug 514796 has been marked as a duplicate of this bug. ***
Comment 20 Charlie Brej 2009-08-05 06:02:09 EDT
Seeing this too.
It may be just me but when I set the volume to 90%. On the next skip it moves to 80% (90%*90%) and then 80%*80% and so on.
Comment 21 Richard Allen 2009-08-05 06:40:15 EDT
Same here with xmms.  I'm pretty sure I also saw this on f10 but I cant verify.   My memory isnt what it used to be ;)
Comment 22 Bastien Nocera 2009-08-07 05:04:29 EDT
*** Bug 516134 has been marked as a duplicate of this bug. ***
Comment 23 Jurgen Kramer 2009-08-09 05:36:55 EDT
I am also experiencing the volume problems.

I've tried the suggested crossfading as a workaround. The results are that the selected track does not even start playing. Modifying the volume crashes rhythbox! So I've disabled crossfading to at least get some sound.

Is there a way to debug the volume changes?
Comment 24 matthias.guentert 2009-08-11 12:55:33 EDT
Same here running rhythmbox-0.12.3-1.fc11.x86_64
Comment 25 Bastien Nocera 2009-08-11 17:22:29 EDT
*** Bug 516880 has been marked as a duplicate of this bug. ***
Comment 26 Andrew Overholt 2009-08-12 15:02:04 EDT
Even with crossfade enabled, sometimes I get large spikes in volume after having rhythmbox paused for a bit.
Comment 27 Soeren Grunewald 2009-08-18 07:43:41 EDT
Same behavior (but in 20% steps), bmpx works fine.

bmpx-0.40.14-8.fc11.x86_64
gstreamer-0.10.24-1.fc11.x86_64
gstreamer-ffmpeg-0.10.7-2.fc11.1.x86_64
gstreamer-plugins-bad-0.10.13-3.fc11.x86_64
gstreamer-plugins-bad-extras-0.10.13-3.fc11.x86_64
gstreamer-plugins-base-0.10.23-3.fc11.x86_64
gstreamer-plugins-flumpegdemux-0.10.15-6.fc11.x86_64
gstreamer-plugins-good-0.10.15-4.fc11.x86_64
gstreamer-plugins-schroedinger-1.0.7-1.fc11.x86_64
gstreamer-plugins-ugly-0.10.12-1.fc11.x86_64
gstreamer-python-0.10.15-1.fc11.x86_64
gstreamer-tools-0.10.24-1.fc11.x86_64
rhythmbox-0.12.3-1.fc11.x86_64
Comment 28 seth vidal 2009-08-18 14:02:16 EDT
Ditto here. It didn't happen on rhythmbox-0.12.1-3.fc11.i586 but does on rhythmbox-0.12.3-1.fc11.i586
Comment 29 jeremy boyd 2009-08-18 15:24:41 EDT
updated to rhythmbox-0.12.3-1 and the problem persists. i'm using a crossfade of 0 seconds to get around the issue
Comment 30 Martin Jürgens 2009-08-18 16:47:17 EDT
seems to be caused by PA as it also happens to me when using totem
Comment 31 J.H.M. Dassen (Ray) 2009-08-19 04:52:29 EDT
I was experiencing this problem with rhythmbox-0.12.3-1.fc11.x86_64.

Starting rhythmbox through "pasuspender -- rhythmbox" did not make a difference. The 0 seconds crossfade workaround did work though.
Comment 32 Ricardo Funke Ormieres 2009-08-20 12:27:56 EDT
(In reply to comment #31)
> I was experiencing this problem with rhythmbox-0.12.3-1.fc11.x86_64.
> 
> Starting rhythmbox through "pasuspender -- rhythmbox" did not make a
> difference. The 0 seconds crossfade workaround did work though.  

Same here
Comment 33 Hin-Tak Leung 2009-08-28 21:15:09 EDT
me too. The crossfade workaround seems to be effective...

$ rpm -q rhythmbox
rhythmbox-0.12.3-1.fc11.x86_64
Comment 34 Jan Alexander 2009-09-05 05:56:00 EDT
Enabling 0 seconds crossfade works for me too, but the volume controls are strange. The lowest 20% in rhythmbox push the main control up to 80%, the remaining 80% in rhythmbox control the last 20% of the main control.

rhythmbox-0.12.3-1.fc11.i586
gstreamer-0.10.24-1.fc11.i586
pulseaudio-0.9.15-14.fc11.i586
Comment 35 Bastien Nocera 2009-09-17 05:53:25 EDT
*** Bug 519382 has been marked as a duplicate of this bug. ***
Comment 36 John Thacker 2009-09-26 21:37:04 EDT
See my comments in bug 501972

I'd be interested to see what hardware people are seeing this problem with. 
With an Audigy 2, I see this bug.  With on-board audio, I see bug 501972
instead.  I think that they're both related with how the audio level is getting
set by totem and rhythmbox.

I cannot reproduce this in banshee with the on-board audio.  The comments in
501972 imply that with banshee that bug (which I think is the same) only
happens after some track changes, not all.
Comment 37 Ricardo Funke Ormieres 2009-09-27 11:27:57 EDT
In my computer it only happens after some track changes too.

Here is my hardware:

# aplay -lL
default:CARD=SI7012
    SiS SI7012, SiS SI7012
    Default Audio Device
front:CARD=SI7012,DEV=0
    SiS SI7012, SiS SI7012
    Front speakers
surround40:CARD=SI7012,DEV=0
    SiS SI7012, SiS SI7012
    4.0 Surround output to Front and Rear speakers
surround41:CARD=SI7012,DEV=0
    SiS SI7012, SiS SI7012
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=SI7012,DEV=0
    SiS SI7012, SiS SI7012
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=SI7012,DEV=0
    SiS SI7012, SiS SI7012
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
iec958:CARD=SI7012,DEV=0
    SiS SI7012, SiS SI7012
    IEC958 (S/PDIF) Digital Audio Output
null
    Discard all samples (playback) or generate zero samples (capture)
**** List of PLAYBACK Hardware Devices ****
card 0: SI7012 [SiS SI7012], device 0: Intel ICH [SiS SI7012]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

# cat /proc/asound/modules 
 0 snd_intel8x0

# lspci 
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 761/M761 Host (rev 01)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS965 [MuTIOL Media IO] (rev 48)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:06.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:07.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:08.0 IDE interface: Silicon Integrated Systems [SiS] Device 0183 (rev 01)
00:09.0 Network controller: RaLink RT2561/RT61 802.11g PCI
00:0a.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: nVidia Corporation G86 [GeForce 8400 GS] (rev a1)

lsmod | grep snd
snd_seq_dummy           2696  0 
snd_seq_oss            31168  0 
snd_seq_midi_event      7012  1 snd_seq_oss
snd_seq                53744  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          6768  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            40352  0 
snd_mixer_oss          17540  1 snd_pcm_oss
snd_intel8x0           30592  1 
snd_ac97_codec        106088  1 snd_intel8x0
ac97_bus                1540  1 snd_ac97_codec
snd_pcm                73512  3 snd_pcm_oss,snd_intel8x0,snd_ac97_codec
snd_timer              21100  2 snd_seq,snd_pcm
snd                    58436  11 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
soundcore               6784  1 snd
snd_page_alloc          8876  2 snd_intel8x0,snd_pcm
Comment 38 Richard Allen 2009-09-27 11:49:55 EDT
[root@rikkilap ~]# lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)


[root@rikkilap ~]# lsmod | grep -i snd
snd_hda_codec_analog    54884  1 
snd_hda_intel          24272  3 
snd_hda_codec          59428  2 snd_hda_codec_analog,snd_hda_intel
snd_hwdep               6724  1 snd_hda_codec
snd_pcm                62796  3 snd_hda_intel,snd_hda_codec
snd_timer              17864  1 snd_pcm
snd                    50336  11 snd_hda_codec_analog,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
soundcore               5476  1 snd
snd_page_alloc          7776  2 snd_hda_intel,snd_pcm
Comment 39 Bastien Nocera 2009-10-16 20:47:29 EDT

*** This bug has been marked as a duplicate of bug 488532 ***

Note You need to log in before you can comment on or make changes to this bug.