Bug 510521 - php-pear-PHPUnit not available in EL5
php-pear-PHPUnit not available in EL5
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: php-pear-PHPUnit (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: Christopher Stone
Fedora Extras Quality Assurance
:
Depends On: 510520
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-09 11:38 EDT by Xavier Bachelot
Modified: 2009-09-28 14:24 EDT (History)
3 users (show)

See Also:
Fixed In Version: 3.3.5-2.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-28 14:24:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
modified spec file (4.78 KB, application/octet-stream)
2009-07-09 11:38 EDT, Xavier Bachelot
no flags Details

  None (edit)
Description Xavier Bachelot 2009-07-09 11:38:38 EDT
Created attachment 351090 [details]
modified spec file

php-pear-PHPUnit is branched but not built for EL5. Latest version from Fedora cannot be rebuilt do to an unsatisfied dependancy on php-pear, but a slightly modified version of the spec downgrading to PHPUnit 3.3.5 works. Modified spec file attached.

Would it be possible to build it ?
Comment 1 Christopher Stone 2009-07-10 22:32:50 EDT
I have to take a look at this, AFAIK, it should already be built for EL5, and the spec file should have the proper php version.
Comment 2 Christopher Stone 2009-07-10 22:36:37 EDT
Ah okay, I was confusing this with another php-pear package of mine.  Yes, I will look at this over the weekend.  Thanks.
Comment 3 Xavier Bachelot 2009-07-12 06:47:30 EDT
There's an error in the spec file, It should not Requires: php-json, but Requires: php-pecl-json instead. See https://bugzilla.redhat.com/show_bug.cgi?id=510520
Comment 4 Xavier Bachelot 2009-08-28 18:40:22 EDT
chris, any news ?
Comment 5 Christopher Stone 2009-09-08 13:57:23 EDT
Hi, sorry, this slipped my mind.  However, I've been going through all my packages and updating them.  Will get to this very soon, I promise. :)
Comment 6 Fedora Update System 2009-09-10 23:42:37 EDT
php-pear-PHPUnit-3.3.5-2.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/php-pear-PHPUnit-3.3.5-2.el5
Comment 7 Fedora Update System 2009-09-12 13:55:11 EDT
php-pear-PHPUnit-3.3.5-2.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update php-pear-PHPUnit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-5/FEDORA-EPEL-2009-0446
Comment 8 Fedora Update System 2009-09-28 14:24:36 EDT
php-pear-PHPUnit-3.3.5-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.