Bug 51087 - Elisp packages "mew" misses mew{en,de}code
Summary: Elisp packages "mew" misses mew{en,de}code
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: mew   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-07 07:23 UTC by Manuel "Chilli" Chakravarty
Modified: 2007-04-18 16:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-02 07:18:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Manuel "Chilli" Chakravarty 2001-08-07 07:23:17 UTC
Description of Problem:

The Elisp package `mew' requires two auxilliary programs implementing MIME
encoding and decoding, which are called `mewencode' and `mewdecode'.
Binaries for these two programs are missing from `xemacs-21.1.14-10'. As a
result MIME emails can neither be composed nor read with mew.

How Reproducible: Every time

Steps to Reproduce:
1. Send yourself MIME email
2. Execute "M-x mew" in XEmacs
3. Move the cursor over the MIME email in +inbox and type `.'

Actual Results:
Error message: "MIME decoding error: mewdecode doesn't exist"

Expected Results:
Decoded MIME email

Additional Information:

The source of this problem seems to be xemacs-sumo-2001-02-04.tar.bz2,
which already lacks the two binaries (I verified this by inspecting the
xemacs source rpm). In the source distribution of "mew" both programs are
contained in a directory named "bin/" among with some other utilities
needed by mew. The contents of the whole directory seems to have been
omitted from xemacs-sumo-2001-02-04.tar.bz2.

Comment 1 Trond Eivind Glomsrxd 2001-08-07 15:42:28 UTC
An elisp package can't contain binaries, which is obviously why it's dropped.
Install the mew package to get the binaries.

Comment 2 Manuel "Chilli" Chakravarty 2001-08-08 08:20:15 UTC
I understand that the xemacs distribution may have dropped the mew binaries from
the Elisp bundle, as they do not want to make it architecture-dependent.  This
is IMHO, however, no excuse for the RH7.1 xemacs package to not ship the mew
binaries (after all, it already contains plenty of binaries).

Given that the xemacs spec file goes to the trouble of putting in an extra init
file for mew, I assume, the intention is to support mew in the xemacs rpm.  The
 impression that support for mew is intended is emphasised by the presence of
the  "im-140-3" package in RH7.1. Without the mew binaries, this support is
quite badly broken.

Comment 3 Trond Eivind Glomsrxd 2001-09-06 19:21:10 UTC
As I wrote, the mew binaries are already present in the mew package in Rawhide.
It should probably split into a mew-common later, though

Comment 4 Satoru SATOH 2001-09-07 10:34:15 UTC
oops. 

all of the elisp files are missing in %%files.
I've fixed at mew-1.94.10

Comment 5 Jens Petersen 2001-10-02 07:18:14 UTC
I made a report about the mew-1.94-9 missing files problem in #54235, since its
a completely separate problem.


Comment 6 Jens Petersen 2001-11-01 09:15:24 UTC
Fixed in rawhide mew-2.0-1.


Note You need to log in before you can comment on or make changes to this bug.