Bug 510961 - FTBFS: amanda-2.6.0p2-9
FTBFS: amanda-2.6.0p2-9
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: amanda (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Daniel Novotny
Fedora Extras Quality Assurance
:
: 511620 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-12 17:18 EDT by Bernard Johnson
Modified: 2009-07-23 09:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 06:50:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a patch (438 bytes, patch)
2009-07-22 06:28 EDT, Daniel Novotny
no flags Details | Diff

  None (edit)
Description Bernard Johnson 2009-07-12 17:18:08 EDT
Description of problem:
amanda-2.6.0p2-9 fails to build from source in rawhide

Version-Release number of selected component (if applicable):
amanda-2.6.0p2-9

How reproducible:
always

Steps to Reproduce:
1. fedora-cvs amanda
2. cd amanda/devel
3. make scratch-build
  
Actual results:
Fails to build.

Expected results:
Should build successfully.

Additional info:
These "BuildRequires" look a little suspect too: dump, tar, mt-st, rsh, openssh-clients.  Are these actually required to build?
Comment 1 Daniel Novotny 2009-07-22 06:23:49 EDT
the error message is this:

/usr/bin/install: will not overwrite just-created `/builddir/build/BUILDROOT/amanda-2.6.0p2-9.fc12.i386/usr/share/man/man8/amcheckdump.8' with `amcheckdump.8'
Comment 2 Daniel Novotny 2009-07-22 06:28:25 EDT
Created attachment 354665 [details]
a patch

The man page is listed twice. removing one occurence fixes this. Seems the install(1) command is more strict now.

btw this is fixed in upstream
Comment 3 Daniel Novotny 2009-07-22 06:50:20 EDT
fixed in amanda-2.6.0p2-10.fc12
Comment 4 Daniel Novotny 2009-07-23 09:37:17 EDT
*** Bug 511620 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.