This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 510966 - PartedException: Assertion (!disk->update_mode) at disk.c:425 in function ped_disk_destroy() failed.
PartedException: Assertion (!disk->update_mode) at disk.c:425 in function ped...
Status: CLOSED DUPLICATE of bug 511907
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Joel Andres Granados
Fedora Extras Quality Assurance
anaconda_trace_hash:4b14ff8ae6d1747f3...
: EasyFix, Patch, Reopened
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-07-12 17:56 EDT by Clyde E. Kunkel
Modified: 2009-07-28 13:11 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 12:50:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (69.52 KB, text/plain)
2009-07-12 17:56 EDT, Clyde E. Kunkel
no flags Details
Attached traceback automatically from anaconda. (63.30 KB, text/plain)
2009-07-13 15:59 EDT, Riku Seppala
no flags Details
fdisk and parted of storage devices (14.97 KB, text/plain)
2009-07-14 09:56 EDT, Clyde E. Kunkel
no flags Details
Attached traceback automatically from anaconda. (39.43 KB, text/plain)
2009-07-15 01:47 EDT, Allen Kistler
no flags Details
anaconda.log (4.39 KB, text/plain)
2009-07-15 02:06 EDT, Allen Kistler
no flags Details
storage.log (2.95 KB, text/plain)
2009-07-15 02:07 EDT, Allen Kistler
no flags Details
syslog (26.92 KB, text/plain)
2009-07-15 02:08 EDT, Allen Kistler
no flags Details
Attached traceback automatically from anaconda. (43.11 KB, text/plain)
2009-07-15 15:43 EDT, Geoff Levand
no flags Details
Attached traceback automatically from anaconda. (45.16 KB, text/plain)
2009-07-16 14:01 EDT, James Laska
no flags Details
Attached traceback automatically from anaconda. (15.84 KB, text/plain)
2009-07-16 14:03 EDT, Lubomir Rintel
no flags Details
Attached traceback automatically from anaconda. (57.03 KB, text/plain)
2009-07-17 08:28 EDT, Stefan Ringel
no flags Details
Attached traceback automatically from anaconda. (38.43 KB, text/plain)
2009-07-17 09:56 EDT, Pavol Rusnak
no flags Details
Attached traceback automatically from anaconda. (60.51 KB, text/plain)
2009-07-17 17:29 EDT, Will Woods
no flags Details
Attached traceback automatically from anaconda. (42.86 KB, text/plain)
2009-07-17 18:05 EDT, Paul W. Frields
no flags Details
Anaconda InstallError output (36.62 KB, text/plain)
2009-07-22 12:48 EDT, Adam Miller
no flags Details
Attached traceback automatically from anaconda. (43.44 KB, text/plain)
2009-07-22 13:20 EDT, Markku Kolkka
no flags Details

  None (edit)
Description Clyde E. Kunkel 2009-07-12 17:56:52 EDT
The following was filed automatically by anaconda:
anaconda 12.2 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/parted/disk.py", line 142, in duplicate
    return Disk(PedDisk=self.__disk.duplicate())
  File "/usr/lib/anaconda/storage/devices.py", line 744, in __init__
    self._origPartedDisk = self.partedDisk.duplicate()
  File "/usr/lib/anaconda/storage/devicetree.py", line 1127, in addUdevDiskDevice
    initcb=cb, initlabel=initlabel, **kwargs)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1209, in addUdevDevice
    device = self.addUdevDiskDevice(info)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1726, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 291, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 92, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 204, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 127, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1346, in nextClicked
    self.anaconda.dispatch.gotoNext()
PartedException: Assertion (!disk->update_mode) at disk.c:425 in function ped_disk_destroy() failed.
Comment 1 Clyde E. Kunkel 2009-07-12 17:56:57 EDT
Created attachment 351408 [details]
Attached traceback automatically from anaconda.
Comment 2 Clyde E. Kunkel 2009-07-12 18:16:22 EDT
trace back occurred during initial "Finding storage devices."  This error occurred on a complex test system that has numerous partitions, LVs, md devices and a raid container.

Same error occurs when trying to install under a Fedora11 VM to a very vanilla disk/partition layout.
Comment 3 Riku Seppala 2009-07-13 15:59:20 EDT
Created attachment 351512 [details]
Attached traceback automatically from anaconda.
Comment 4 Joel Andres Granados 2009-07-14 07:51:44 EDT
Can you pls post the output of

1. `fdisk -l DEVICE` and
2. `parted DEVICE print free`

Thx.
Comment 5 Clyde E. Kunkel 2009-07-14 09:56:03 EDT
Created attachment 351587 [details]
fdisk and parted of storage devices

As requested.
Comment 6 Allen Kistler 2009-07-15 01:47:18 EDT
Created attachment 353779 [details]
Attached traceback automatically from anaconda.
Comment 7 Allen Kistler 2009-07-15 02:06:46 EDT
Created attachment 353784 [details]
anaconda.log

Using boot.iso/install.img dated 15 July 2009 00:17 on the following existing disk layout ...

fdisk -l /dev/sda
   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          13      104391   83  Linux
/dev/sda2              14          78      522112+  82  Linux swap / Solaris
/dev/sda3              79        1044     7759395   8e  Linux LVM

pvs
  PV         VG   Fmt  Attr PSize PFree
  /dev/sda3  vg0  lvm2 a-   7.38G 3.75G
vgs
  VG   #PV #LV #SN Attr   VSize VFree
  vg0    1   1   0 wz--n- 7.38G 3.75G
lvs
  LV   VG   Attr   LSize Origin Snap%  Move Log Copy%  Convert
  f9   vg0  -wi-ao 3.62G
Comment 8 Allen Kistler 2009-07-15 02:07:47 EDT
Created attachment 353785 [details]
storage.log
Comment 9 Allen Kistler 2009-07-15 02:08:12 EDT
Created attachment 353786 [details]
syslog
Comment 10 Geoff Levand 2009-07-15 15:43:49 EDT
Created attachment 353889 [details]
Attached traceback automatically from anaconda.
Comment 11 James Laska 2009-07-16 14:01:44 EDT
Created attachment 354025 [details]
Attached traceback automatically from anaconda.
Comment 12 Lubomir Rintel 2009-07-16 14:03:53 EDT
Created attachment 354026 [details]
Attached traceback automatically from anaconda.
Comment 13 James Laska 2009-07-16 14:05:14 EDT
FWIW ... I also see the following backtrace on the serial console when this failure occurs:

Backtrace has 20 calls on stack:
  20: /lib/libparted-1.9.so.0(ped_assert+0x43) [0xcd8793]
  19: /lib/libparted-1.9.so.0(ped_disk_destroy+0x9b) [0xcde24b]
  18: /lib/libparted-1.9.so.0(ped_disk_duplicate+0x1c2) [0xcdfa52]
  17: /usr/lib/python2.6/site-packages/_pedmodule.so(py_ped_disk_duplicate+0x2c) [0xd795ec]
  16: /usr/lib/libpython2.6.so.1.0(PyCFunction_Call+0x12a) [0x41fbda]
  15: /usr/lib/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x4a0c) [0x47b97c]
  14: /usr/lib/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x5345) [0x47c2b5]
  13: /usr/lib/libpython2.6.so.1.0(PyEval_EvalCodeEx+0x7b2) [0x47d122]
  12: /usr/lib/libpython2.6.so.1.0 [0x40c040]
  11: /usr/lib/libpython2.6.so.1.0(PyObject_Call+0x5c) [0x3df72c]
  10: /usr/lib/libpython2.6.so.1.0 [0x3f5574]
  9: /usr/lib/libpython2.6.so.1.0(PyObject_Call+0x5c) [0x3df72c]
  8: /usr/lib/libpython2.6.so.1.0 [0x43b2e6]
  7: /usr/lib/libpython2.6.so.1.0 [0x439c75]
  6: /usr/lib/libpython2.6.so.1.0(PyObject_Call+0x5c) [0x3df72c]
  5: /usr/lib/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x3492) [0x47a402]
  4: /usr/lib/libpython2.6.so.1.0(PyEval_EvalCodeEx+0x7b2) [0x47d122]
  3: /usr/lib/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x43f1) [0x47b361]
  2: /usr/lib/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x5345) [0x47c2b5]
  1: /usr/lib/libpython2.6.so.1.0(PyEval_EvalFrameEx+0x5345) [0x47c2b5]
Comment 14 James Laska 2009-07-16 14:08:09 EDT
Setting severity to high based on http://fedoraproject.org/wiki/BugZappers/BugStatusWorkFlow#Severity
Comment 15 Stefan Ringel 2009-07-17 08:28:24 EDT
Created attachment 354133 [details]
Attached traceback automatically from anaconda.
Comment 16 Pavol Rusnak 2009-07-17 09:56:32 EDT
Created attachment 354146 [details]
Attached traceback automatically from anaconda.
Comment 17 Will Woods 2009-07-17 17:29:40 EDT
Created attachment 354218 [details]
Attached traceback automatically from anaconda.
Comment 18 Paul W. Frields 2009-07-17 18:05:43 EDT
Created attachment 354227 [details]
Attached traceback automatically from anaconda.
Comment 19 Lubomir Rintel 2009-07-18 06:38:22 EDT
Joel, I think there's a typo in your pop-push-errno patch. (A reversed conditional.)

I've commited this into parted-1_9_0-3_20090610git32dc_fc12; if you've submitted that upstream, you may want to resubmit it with the fix applied.
Comment 20 Clyde E. Kunkel 2009-07-21 13:04:11 EDT
Could not test with anaconda 12.3 due to https://bugzilla.redhat.com/show_bug.cgi?id=513021 networking won't come up.
Comment 21 Allen Kistler 2009-07-21 19:13:21 EDT
I was able not to get this error with anaconda-12.3 on today's (21 July 2009) boot.iso.  I ran into a different show-stopping bug at a later point, but that will be a different report.
Comment 22 Joel Andres Granados 2009-07-22 07:59:52 EDT
Ludomir:
Thx a lot for the fix.  I have not yet posted this upstream (was waiting for testing :).

I'm closing this based on comment #21
Comment 23 Adam Miller 2009-07-22 12:48:11 EDT
Created attachment 354735 [details]
Anaconda InstallError output
Comment 24 Adam Miller 2009-07-22 12:48:48 EDT
Bug still exists, please see the attachment I posted.
Comment 25 Adam Miller 2009-07-22 12:50:50 EDT
Wrong bug, reclosing.
Comment 26 Markku Kolkka 2009-07-22 13:20:55 EDT
Created attachment 354744 [details]
Attached traceback automatically from anaconda.
Comment 27 Clyde E. Kunkel 2009-07-28 10:24:46 EDT
Isn't this essentially the same error as in bz 511907?  If so, shouldn.t it be a dup and not closed?
Comment 28 Andy Lindeberg 2009-07-28 13:11:16 EDT
Yes, you're correct. Duping.

*** This bug has been marked as a duplicate of bug 511907 ***

Note You need to log in before you can comment on or make changes to this bug.