Bug 511009 - gimp gets stuck on startup and never finishes launching
gimp gets stuck on startup and never finishes launching
Status: CLOSED DUPLICATE of bug 510209
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-07-13 04:44 EDT by Nicolas Mailhot
Modified: 2009-07-14 13:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 13:48:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2009-07-13 04:44:44 EDT
Description of problem:

gimp gets stuck on startup and never finishes launching


Version-Release number of selected component (if applicable):

gimp-2:2.6.6-6.fc12.x86_64

$ gdb gimp
GNU gdb (GDB) Fedora (6.8.50.20090302-39.fc12)
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
(gdb) run
Starting program: /usr/bin/gimp 
[Thread debugging using libthread_db enabled]
[New Thread 0x7ffff0840910 (LWP 4623)]
[New Thread 0x7fffefe3f910 (LWP 4624)]

(gimp:4620): GLib-GObject-WARNING **: specified class size for type `GimpOperationPointFilter' is smaller than the parent type's `GeglOperationPointFilter' class size

(gimp:4620): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(gimp:4620): GLib-GObject-CRITICAL **: g_type_register_static: assertion `parent_type > 0' failed

(gimp:4620): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(gimp:4620): GLib-GObject-WARNING **: cannot retrieve class for invalid (unclassed) type `<invalid>'
^C
Program received signal SIGINT, Interrupt.
pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
261		movl	(%rsp), %edi
Current language:  auto; currently asm
(gdb) bt
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x0000003441c626d2 in IA__g_once_init_enter_impl (value_location=0xaa7058) at gthread.c:216
#2  0x0000000000000000 in ?? ()
Comment 1 Matthew Miller 2009-07-14 13:48:16 EDT

*** This bug has been marked as a duplicate of bug 510209 ***

Note You need to log in before you can comment on or make changes to this bug.