Bug 510209 - Gimp hangs on startup
Gimp hangs on startup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
rawhide
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
: 511009 512546 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-08 07:30 EDT by Jonathan Kamens
Modified: 2009-07-20 07:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-17 02:13:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2009-07-08 07:30:58 EDT
In Rawhide, Gimp hangs on startup after printing these errors:

GLib-GObject-WARNING **: specified class size for type
`GimpOperationPointFilter' is smaller than the parent type's
`GeglOperationPointFilter' class size

(gimp:2808): GLib-CRITICAL **: g_once_init_leave: assertion
`initialization_value != 0' failed

(gimp:2808): GLib-GObject-CRITICAL **: g_type_register_static: assertion
`parent_type > 0' failed

(gimp:2808): GLib-CRITICAL **: g_once_init_leave: assertion
`initialization_value != 0' failed

(gimp:2808): GLib-GObject-WARNING **: cannot retrieve class for invalid
(unclassed) type `<invalid>'

pstree shows that there are three gimp processes running, a parent and two
children, and that all three are hung in a futex call.  I tried moving all of
my ~/.gimp* directories out of the way before launching gimp, and it didn't
help.

I have gimp-2.6.6-6.fc12.i586, along with all other current packages from
today's Rawhide.
Comment 1 Matthew Miller 2009-07-12 09:42:15 EDT
Confirming as broken on both of my x86_64 boxes:

(gimp:9168): GLib-GObject-WARNING **: specified class size for type `GimpOperationPointFilter' is smaller than the parent type's `GeglOperationPointFilter' class size

(gimp:9168): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(gimp:9168): GLib-GObject-CRITICAL **: g_type_register_static: assertion `parent_type > 0' failed

(gimp:9168): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(gimp:9168): GLib-GObject-WARNING **: cannot retrieve class for invalid (unclassed) type `<invalid>'
Comment 2 Matthew Miller 2009-07-14 13:48:16 EDT
*** Bug 511009 has been marked as a duplicate of this bug. ***
Comment 3 Matthew Miller 2009-07-15 14:14:44 EDT
I rebuilt the gimp-2.6.6-6 rpm on current rawhide (rpmbuild -bb), and the rebuild package runs without error.
Comment 4 Pete Zaitcev 2009-07-16 00:20:55 EDT
The gimp-2.6.6-6.fc12.x86_64 is current in the Rawhide, and it hangs here.
Would someone be so kind to bump the release and rebuild? There's no newer
package in Koji.
Comment 5 Nils Philippsen 2009-07-16 04:52:50 EDT
2.6.6-7 is building at the moment. I kind of missed this while discussing with upstream that bumping the soname when changing the ABI would be a good thing ;-/.
Comment 6 Pete Zaitcev 2009-07-17 02:13:17 EDT
Confirmed fixed in gimp-2.6.6-7.fc12.x86_64, closing.
Comment 7 Nils Philippsen 2009-07-20 07:55:28 EDT
*** Bug 512546 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.