Bug 511169 - anaconda addUdevDevice
anaconda addUdevDevice
Status: CLOSED DUPLICATE of bug 510033
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ppc Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:0b403cbf8524b7b5d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-13 20:26 EDT by Geoff Levand
Modified: 2009-07-14 11:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 11:35:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (44.96 KB, text/plain)
2009-07-13 20:26 EDT, Geoff Levand
no flags Details

  None (edit)
Description Geoff Levand 2009-07-13 20:26:45 EDT
The following was filed automatically by anaconda:
anaconda 12.2 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicetree.py", line 1286, in addUdevDevice
    if device.name in self.protectedDevNames:
  File "/usr/lib/anaconda/storage/devicetree.py", line 1791, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 291, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 92, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 204, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 127, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 721, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 964, in <module>
    anaconda.intf.run(anaconda)
AttributeError: 'NoneType' object has no attribute 'name'
Comment 1 Geoff Levand 2009-07-13 20:26:49 EDT
Created attachment 351541 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-07-14 11:35:43 EDT

*** This bug has been marked as a duplicate of bug 510033 ***

Note You need to log in before you can comment on or make changes to this bug.