This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 510033 - AttributeError: 'NoneType' object has no attribute 'name'
AttributeError: 'NoneType' object has no attribute 'name'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
high Severity urgent
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
anaconda_trace_hash:e7fc78ac877b6dc08...
:
: 510039 510396 511169 511268 (view as bug list)
Depends On:
Blocks: F12Blocker/F12FinalBlocker F12Alpha/F12AlphaBlocker
  Show dependency treegraph
 
Reported: 2009-07-07 10:08 EDT by Clyde E. Kunkel
Modified: 2009-08-14 13:00 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 510039 (view as bug list)
Environment:
Last Closed: 2009-08-04 19:20:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (2.05 MB, text/plain)
2009-07-07 10:08 EDT, Clyde E. Kunkel
no flags Details
updates with fix for 510033 (92.23 KB, application/octet-stream)
2009-07-21 12:43 EDT, David Lehman
no flags Details

  None (edit)
Description Clyde E. Kunkel 2009-07-07 10:08:28 EDT
The following was filed automatically by anaconda:
anaconda 12.1 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicetree.py", line 1286, in addUdevDevice
    if device.name in self.protectedDevNames:
  File "/usr/lib/anaconda/storage/devicetree.py", line 1791, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 291, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/iw/partition_gui.py", line 669, in getPrev
    self.storage.reset()
  File "/usr/lib/anaconda/gui.py", line 1333, in prevClicked
    self.currentWindow.getPrev ()
AttributeError: 'NoneType' object has no attribute 'name'
Comment 1 Clyde E. Kunkel 2009-07-07 10:08:40 EDT
Created attachment 350802 [details]
Attached traceback automatically from anaconda.
Comment 2 Clyde E. Kunkel 2009-07-07 10:17:54 EDT
This traceback occurred only after seeing that LVs and raids were not detected during storage probes and clicking the back button, going to tty2 and activating the LVs (lvm vgchange -ay) and then going back to tty6 and clicking next (custom partitioning having already been selected).

So, looks like two bugs--this one and a new one: anaconda 12.1 not detecting LVM and raid (will enter bz shortly).
Comment 3 Andy Lindeberg 2009-07-07 14:01:19 EDT
*** Bug 510039 has been marked as a duplicate of this bug. ***
Comment 4 Chris Lumens 2009-07-09 10:23:20 EDT
*** Bug 510396 has been marked as a duplicate of this bug. ***
Comment 5 Chris Lumens 2009-07-14 11:35:38 EDT
*** Bug 511268 has been marked as a duplicate of this bug. ***
Comment 6 Chris Lumens 2009-07-14 11:35:43 EDT
*** Bug 511169 has been marked as a duplicate of this bug. ***
Comment 7 James Laska 2009-07-16 14:08:14 EDT
Setting severity to high based on http://fedoraproject.org/wiki/BugZappers/BugStatusWorkFlow#Severity
Comment 8 Adam Williamson 2009-07-17 14:53:29 EDT
raising to urgent: this is affecting a wide range of (and possibly all) rawhide installations.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Adam Williamson 2009-07-17 14:54:22 EDT
Blocks Fedora 12 Alpha for obvious reasons.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Denise Dumas 2009-07-17 15:41:15 EDT
Dlehman is working this one, he has a patch that would fix the immediate
problem of the traceback, but it seems like something more is going on that
needs to be identified. So work continues, but progress is being made.
Comment 11 Jens Petersen 2009-07-20 21:41:01 EDT
Cool

(In reply to comment #4)
> *** Bug 510396 has been marked as a duplicate of this bug. ***  

Note there are 6 backtraces attached to this report also.
Comment 12 David Lehman 2009-07-21 12:43:17 EDT
Created attachment 354519 [details]
updates with fix for 510033

Please try the attached updates image. It is also available at http://dlehman.fedorapeople.org/510033.img .

Here's a link to some help on using updates from the network:

  http://fedoraproject.org/wiki/Anaconda/Updates#Updates_from_the_Network
Comment 13 Clyde E. Kunkel 2009-07-21 16:25:12 EDT
Apparently, the updates dialogue screen comes after the network screen.  Can't apply updates via network or update floppy or key since anaconda is failing at the network screen when using askmethod to get to a network.

Is there a way to invoke updates earlier?
Comment 14 David Lehman 2009-07-21 16:37:02 EDT
The link I provided describes a variety of options for specifying an updates image. You only need to put updates=http://dlehman.fedorapeople.org/510033.img on the command line when booting. You can find information about how to specify your network configuration on the command line here:

  http://fedoraproject.org/wiki/Anaconda/Options
Comment 15 Andy Lindeberg 2009-07-23 10:11:05 EDT
The fix for this should be present in anaconda 12.4.
Comment 16 Adam Williamson 2009-07-23 14:12:58 EDT
can people please test this as a matter of urgency? Thanks.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 17 Clyde E. Kunkel 2009-07-23 14:21:37 EDT
Can't test since still cannot get a network connection with 12.4.
Comment 18 Adam Miller 2009-07-23 15:33:54 EDT
Works for me with 12.5, I snagged it from koji on a live image I composed (assuming the mirrors just haven't sync'd yet). I was able to get a successful complete install from an "unofficial" rawhide composed livecd.
Comment 19 Clyde E. Kunkel 2009-07-23 20:47:58 EDT
Correcting comment #17:  ...with 12.5 VICE ...with 12.4
Comment 20 Clyde E. Kunkel 2009-07-25 12:15:03 EDT
No joy due to 511907...
Comment 21 Clyde E. Kunkel 2009-07-28 10:27:45 EDT
Still can't verify fixed due to failing anaconda with rawhide image from 20090728. Bz 511907 (and maybe dup 513725).
Comment 22 Clyde E. Kunkel 2009-08-01 14:43:26 EDT
Can't conclusively verify this is fixed since traceback occurs near what appears to be the end of storage prob.  See bz 499854 which was closed due to insufficient data.  However, since this traceback occurred only after storage prob completed without finding LVs and raids, the error has either been resolved now or has morphed into something more insidious.

Please note:  Fedoras 9, 10 and 11 alpha installed on this system.  Have not had a successful install since except by installed fedora 10 and then doing an update install of 11.
Comment 23 Adam Williamson 2009-08-04 19:20:41 EDT
Two reports is good enough for me to mark this one fixed. Can always re-open if appropriate.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 24 Geoff Levand 2009-08-14 13:00:13 EDT
Just to report, I no longer see this bug on the PS3 game console.

-Geoff

Note You need to log in before you can comment on or make changes to this bug.