Bug 51178 - Failure of --target tag in rpm-4.0.3
Summary: Failure of --target tag in rpm-4.0.3
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: roswell
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-08 06:54 UTC by Alan Brady
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-08 06:54:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alan Brady 2001-08-08 06:54:11 UTC
Description of Problem:

The tags for rebuilding SRPMS don't always work. Specifically
--target=<target> fails.

How Reproducible:

Can reproduce 100% of the time.

Steps to Reproduce:

1. rpm --rebuild <srpms> --target=<target> 
2. rpm -ta <.gz or .bz2 file> --target=<target>
3. rpm -tb <.gz or .bz2 file> --target=<target>

Actual Results:

--target=<target>: unknown option
ex. --target=i686: unknown option

Expected Results:

Build of binary and possibly srpms with the binary in the proper
architecture and optimization.

Additional Information:

This seems to be a bug with rpm-4.0.3 since I had the same problem
previously when using the same version out of Rawhide. I can go back to the
version with 7.1 and everything works normally.

Comment 1 Jeff Johnson 2001-08-08 12:17:01 UTC
Either type
	rpmbuild ... --target=<target>
or
	rpm -ba ... --target <target>

The 1st command is what will persist in the future.


Note You need to log in before you can comment on or make changes to this bug.