Bug 512731 - SSSD: Services are dead but pid file exists
SSSD: Services are dead but pid file exists
Status: CLOSED DUPLICATE of bug 512733
Product: freeIPA
Classification: Community
Component: ipa-client (Show other bugs)
2.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Simo Sorce
Chandrasekar Kannan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-20 11:37 EDT by Jenny Galipeau
Modified: 2015-01-04 18:39 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-30 11:55:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jenny Galipeau 2009-07-20 11:37:25 EDT
Description of problem:

If you try to start SSSD services with an invalid sssd.conf file - example: no domains configured.  The service appears to start successfully and returns 0.


[root@localhost sssd]# service sssd start
Starting sssd:                                             [  OK  ]

[root@localhost sssd]# echo $?
0

[root@localhost sssd]# service sssd status
sssd dead but pid file exists

[root@localhost sssd]# ps -ef | grep sssd
root     11646 11544  0 11:36 pts/0    00:00:00 grep sssd

This is true for both Fedora 11 and RHEL 5.3.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.  yum install sssd
2.  do not edit sssd.conf file, but use default with no domains configured and start SSSD
    service sssd start
3.  echo $?
4.  service sssd status
5.  ps -ef | grep sssd

Actual results:
Service appears to start successfully
return code status is 0
pid file is created even service did not start

Expected results:
Appropriate error message 
non 0 return code status
pid file not created
Additional info:
Comment 1 Jenny Galipeau 2009-07-20 11:47:22 EDT
bug also logged against F11 - bug #512733
Comment 2 Jenny Galipeau 2009-07-30 11:55:56 EDT
closing as duplicate

*** This bug has been marked as a duplicate of bug 512733 ***

Note You need to log in before you can comment on or make changes to this bug.