Bug 512973 - -net channel is broken in qemu 0.10.5
-net channel is broken in qemu 0.10.5
Status: CLOSED DUPLICATE of bug 513249
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-21 10:45 EDT by Richard W.M. Jones
Modified: 2010-03-16 13:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 13:34:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2009-07-21 10:45:43 EDT
Since this patch:

http://git.savannah.gnu.org/cgit/qemu.git/commit/?id=c92ef6a22d3c71538fcc48fb61ad353f7ba03b62

guestfwd/vmchannel is now officially broken upstream.  Fucking hell.
Comment 1 Mark McLoughlin 2009-07-21 10:57:37 EDT
How exactly is it broken? Looks like it's 'just a bug', since the code is all still there AFAICS

I'm guessing you're already working on reporting it upstream, though ?
Comment 2 Mark McLoughlin 2009-07-21 11:00:15 EDT
Ah, I see the upstream report now, but can't link to it until the archives update. Subject is:

  [Qemu-devel] guestfwd option doesn't allow supplementary , server, nowait
Comment 3 Richard W.M. Jones 2009-07-21 11:28:43 EDT
At the moment I know that 'make check' fails after
the first test.  It just hangs there.  Still
investigating.
Comment 4 Richard W.M. Jones 2009-07-22 13:31:15 EDT
A patch was posted upstream which fixes this:

http://lists.gnu.org/archive/html/qemu-devel/2009-07/msg01753.html

I'm going to open a new bug (against qemu) to get this
patch incorporated.
Comment 5 Richard W.M. Jones 2009-07-22 13:34:48 EDT

*** This bug has been marked as a duplicate of bug 513249 ***

Note You need to log in before you can comment on or make changes to this bug.