Bug 513249 - guestfwd broken in qemu Rawhide
guestfwd broken in qemu Rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
: 512973 514507 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-22 13:34 EDT by Richard W.M. Jones
Modified: 2009-07-29 09:32 EDT (History)
7 users (show)

See Also:
Fixed In Version: qemu-0.10.50-13.kvm88.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-28 03:23:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2009-07-22 13:34:34 EDT
Description of problem:

The -net user,guestfwd=... / -net channel option is broken
in Rawhide at the moment.

The following upstream patch fixes this, please apply it:

http://lists.gnu.org/archive/html/qemu-devel/2009-07/msg01753.html

Version-Release number of selected component (if applicable):

qemu-0.10.50-12.kvm88.fc12.i586

How reproducible:

Always.

Steps to Reproduce:

See this thread:
http://lists.gnu.org/archive/html/qemu-devel/2009-07/threads.html#01654
  
Actual results:

When using guestfwd, packets sent by the guest to the host arrive,
but packets sent by the host to the guest disappear.

Expected results:

Two-way communications.

Additional info:

I have checked that the upstream patch fixes this problem.
Comment 1 Richard W.M. Jones 2009-07-22 13:34:48 EDT
*** Bug 512973 has been marked as a duplicate of this bug. ***
Comment 2 Mark McLoughlin 2009-07-28 03:23:27 EDT
* Thu Jul 23 2009 Glauber Costa <glommer@redhat.com> - 2:0.10.50-13.kvm88
- Fix bug 513249, -net channel option is broken
Comment 3 Richard W.M. Jones 2009-07-29 09:32:16 EDT
*** Bug 514507 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.