Bug 51328 - Anaconda crashes when setting up boot loader
Anaconda crashes when setting up boot loader
Status: CLOSED DUPLICATE of bug 50791
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
roswell
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-09 11:19 EDT by Need Real Name
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-09 11:21:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump.txt (10.14 KB, text/plain)
2001-08-09 11:21 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-08-09 11:19:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT; JP Morgan)

Description of problem:
Was installing a version of Roswell on a clean box and it gave a traceback 
during bootloader setup - looks like someone is trying to add 'None' to a 
string :)

How reproducible:
Didn't try

Steps to Reproduce:
1. Just install roswell i guess
2.
3.
	

Additional info:

This is the traceback, more in attachments

Traceback (innermost last):
  File "/usr/bin/anaconda", line 608, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/gui.py", line 348, in run
    self.icw.run (self.runres, configFileData)
  File "/usr/lib/anaconda/gui.py", line 776, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2608, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/anaconda/gui.py", line 495, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 122, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 397, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 139, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 204, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/bootloader.py", line 658, in writeBootloader
    justConfigFile)
  File "/usr/lib/anaconda/bootloader.py", line 540, in write
    justConfig | (self.useGrubVal))
  File "/usr/lib/anaconda/bootloader.py", line 523, in writeLilo
    kernelList, chainList, defaultDev)
  File "/usr/lib/anaconda/bootloader.py", line 498, in getBootloaderConfig
    config.addEntry("boot", '/dev/' + liloTarget, replace = 0)
TypeError: illegal argument type for built-in operation

Local variables in innermost frame:
chainList: []
config: prompt
timeout=50
default=linux

image=/boot/vmlinuz-2.4.6-3.1smp
	label=linux
	initrd=/boot/initrd-2.4.6-3.1smp.img
	read-only
	root=/dev/sda1

image=/boot/vmlinuz-2.4.6-3.1
	label=linux-up
	initrd=/boot/initrd-2.4.6-3.1.img
	read-only
	root=/dev/sda1

self: <bootloader.x86BootloaderInfo instance at 854f478>
langs: LANG="en_US"
SUPPORTED="en_US:en:ru_RU.koi8r:ru_RU:ru:ru_UA:ru:uk_UA:uk"
SYSFONT="lat0-16"
SYSFONTACM="iso01"

fsset: <fsset.FileSystemSet instance at 8640558>
bl: <bootloader.x86BootloaderInfo instance at 854f478>
defaultDev: sda1
liloTarget: None
kernelList: [('linux', 'Red Hat Linux', '2.4.6-3.1smp'), ('linux-up', 'Red 
Hat Linux-up', '2.4.6-3.1')]
instRoot: /mnt/sysimage
Comment 1 Need Real Name 2001-08-09 11:21:15 EDT
Created attachment 27033 [details]
anacdump.txt
Comment 2 Jeremy Katz 2001-08-09 11:43:33 EDT

*** This bug has been marked as a duplicate of 50791 ***

Note You need to log in before you can comment on or make changes to this bug.