Bug 513451 - PulseAudio does not play anything after a while
PulseAudio does not play anything after a while
Status: CLOSED DUPLICATE of bug 509054
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
11
i686 Linux
low Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-23 13:33 EDT by Dag
Modified: 2009-07-24 20:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-24 20:28:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/messages (15.50 KB, text/plain)
2009-07-23 13:33 EDT, Dag
no flags Details
alsa-info (19.56 KB, text/plain)
2009-07-23 13:34 EDT, Dag
no flags Details

  None (edit)
Description Dag 2009-07-23 13:33:49 EDT
Created attachment 354894 [details]
/var/log/messages

Description of problem:
This issue happens sometimes, most of the time all is OK.
So sometimes, When I listen to some sound file, the sound stops and the application (i.e. AUdacious or Exaile) continues to play as if nothing was wrong.
But the Gnome volume applet is not working anymore, pulseaudio is taking all available CPU.
I can run some other audio app and play some sound file, then the same happens to the new app.
Sometimes the app is not able to recover from that "sound stall" sometimes, the sound gets back, then off again.
It generates many logs in /var/log/messages.
The keyboard shortcuts volume up/down doesn't work anymore (the little bargraph window doesn't show up either) but the keys are working fine and sending the correct keyboard events.
A reboot of the machine fixes it all... until the next time which is generally several days later. (my computer is on every day I reboot or turn off my computer every night).

Version-Release number of selected component (if applicable):
~]$ rpm -qa | grep -i pulse
pulseaudio-libs-0.9.15-14.fc11.i586
pulseaudio-0.9.15-14.fc11.i586
pulseaudio-module-gconf-0.9.15-14.fc11.i586
alsa-plugins-pulseaudio-1.0.20-2.fc11.i586
xine-lib-pulseaudio-1.1.16.3-2.fc11.i586
pulseaudio-libs-zeroconf-0.9.15-14.fc11.i586
pulseaudio-module-bluetooth-0.9.15-14.fc11.i586
pulseaudio-utils-0.9.15-14.fc11.i586
pulseaudio-libs-glib2-0.9.15-14.fc11.i586
pulseaudio-module-x11-0.9.15-14.fc11.i586
wine-pulseaudio-1.1.23-1.fc11.i586
~]$ rpm -qa | grep -i alsa
alsa-plugins-pulseaudio-1.0.20-2.fc11.i586
alsa-lib-1.0.20-1.fc11.i586
alsa-utils-1.0.20-3.fc11.i586
~]$ uname -a
Linux laptop.local 2.6.29.6-213.fc11.i686.PAE #1 SMP Tue Jul 7 20:59:29 EDT 2009 i686 i686 i386 GNU/Linux

How reproducible:
Well, it's kind of random... I can't find any reproductibility method.
It just happends sometimes.

Steps to Reproduce:
1. play some sound files with Audacious, or Exaile
2. wait for sound to stop (it can take take days to appear)
3. look at volume applet, /var/log/messages, top
  
Actual results:
I'm getting this kind of messages:
Jul 23 18:34:42 laptop pulseaudio[8694]: asyncq.c: q overrun, queuing locally
Jul 23 18:34:47 laptop pulseaudio[8694]: ratelimit.c: 8298 events suppressed
Jul 23 18:36:21 laptop pulseaudio[8810]: pid.c: Stale PID file, overwriting.
Jul 23 18:36:22 laptop pulseaudio[8810]: alsa-sink.c: Device hw:1 is modem, refusing further initialization.
Jul 23 18:36:22 laptop pulseaudio[8810]: alsa-source.c: Device hw:1 is modem, refusing further initialization.
Jul 23 18:36:27 laptop pulseaudio[8810]: alsa-sink.c: Increasing minimal latency to 26,00 ms
Jul 23 18:36:31 laptop pulseaudio[8810]: alsa-sink.c: Increasing wakeup watermark to 15,99 ms
Jul 23 18:36:31 laptop pulseaudio[8810]: alsa-util.c: snd_pcm_avail() returned a value that is exceptionally large: 4294963268 bytes (24347864 ms).
Jul 23 18:36:31 laptop pulseaudio[8810]: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
Jul 23 18:36:31 laptop pulseaudio[8810]: alsa-util.c: snd_pcm_dump():



Expected results:
Sound must not stop. pulseaudio must not take 100%CPU and issue so much logs, applications must not crash because pulseaudio gets kind of unresponsive.

Additional info:
I'm not sure that this bug is already reported, I saw some bugs reports displaying nearly the same issue or errors, but they don't seem to be the same.
Comment 1 Dag 2009-07-23 13:34:50 EDT
Created attachment 354895 [details]
alsa-info
Comment 2 Dag 2009-07-23 18:29:36 EDT
Okay, in fact, after rebooting, this problem still occurs, I must power OFF completely, then power ON to get rid of this problem.

This problem seemes to arise with flash player (npviewer.bin) running at the moment PA crashes.
But it's only a supposition, as it may just be a coincidence.

maybe useful:
~]$ rpm -qa | grep -i adobe
adobe-release-i386-1.0-1.noarch
~]$ rpm -qa | grep -i flash
flash-plugin-10.0.22.87-release.i386
~]$ rpm -qa | grep -i firefox
firefox-3.5.1-1.fc11.i586
Comment 3 Dag 2009-07-24 04:14:22 EDT
OK, I've tested a bit more:
there is no link with flash player because this morning PA did malfunction everytime I played a sound
I rebooted and powered OFF/ON several times but everytime it malfunctioned
This is with kernel 
Linux laptop.local 2.6.29.6-213.fc11.i686.PAE #1 SMP Tue Jul 7 20:59:29 EDT
2009 i686 i686 i386 GNU/Linux

I rebooted once more, choosing the preceding kernel
Linux laptop.local 2.6.29.5-191.fc11.i686.PAE #1 SMP Tue Jun 16 23:19:53 EDT 2009 i686 i686 i386 GNU/Linux

And everything is fine now.
So it must be something in the new kernel.
Comment 4 Laurent Baum 2009-07-24 19:19:00 EDT
Hi,

I can reproduce the error as well as solve the issue by boot F11 with kernel-2.6.29.5-191.fc11.i586 !


#pulse versions
rpmquery -a | grep pulse
xine-lib-pulseaudio-1.1.16.3-2.fc11.i586
pulseaudio-module-x11-0.9.15-14.fc11.i586
pulseaudio-0.9.15-14.fc11.i586
kde-settings-pulseaudio-4.2-10.20090430svn.fc11.noarch
alsa-plugins-pulseaudio-1.0.20-2.fc11.i586
pulseaudio-utils-0.9.15-14.fc11.i586
pulseaudio-libs-0.9.15-14.fc11.i586

#alsa versions
rpmquery -a | grep alsa
alsa-utils-1.0.20-3.fc11.i586
alsa-plugins-pulseaudio-1.0.20-2.fc11.i586
alsa-lib-1.0.20-1.fc11.i586

#kernel versions
rpmquery -a | grep kernel
kernel-2.6.29.6-213.fc11.i586
kernel-2.6.29.4-167.fc11.i586
kernel-firmware-2.6.29.6-213.fc11.noarch
kernel-2.6.29.5-191.fc11.i586
kerneloops-0.12-5.fc11.i586

Kernel causing the problem:
kernel-2.6.29.6-213.fc11.i586

All good when running:
Linux lietkynes 2.6.29.5-191.fc11.i586 #1 SMP Tue Jun 16 23:11:39 EDT 2009 i686 i686 i386 GNU/Linux
Comment 5 Lennart Poettering 2009-07-24 20:28:48 EDT
Jul 23 18:36:31 laptop pulseaudio[8810]: alsa-util.c: snd_pcm_avail() returned
a value that is exceptionally large: 4294963268 bytes (24347864 ms).

Yur sound driver is broken. This triggers CPU overload in PA so that it will terminate itself after a while.

*** This bug has been marked as a duplicate of bug 509054 ***

Note You need to log in before you can comment on or make changes to this bug.