This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 509054 - intel8x0 fails with pulseaudio
intel8x0 fails with pulseaudio
Status: CLOSED DUPLICATE of bug 506075
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
: 513451 513484 513763 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-01 00:07 EDT by James
Modified: 2009-07-29 04:12 EDT (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-29 04:12:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output of my systems alsa-info (19.33 KB, text/plain)
2009-07-14 07:04 EDT, Stan Trzmiel
no flags Details
Messages log with lots of alsa related errors (421.79 KB, text/plain)
2009-07-14 07:10 EDT, Stan Trzmiel
no flags Details

  None (edit)
Description James 2009-07-01 00:07:37 EDT
When playing a sound, the sound card plays a short repeated sound (it sounds like a screeching broken record).  The lspci entry for the sound card is:

00:1f.5 Multimedia audio controller: Intel Corporation 82801BA/BAM AC'97 Audio Controller (rev 02)
	Subsystem: Dell Device 00c6
	Flags: bus master, medium devsel, latency 0, IRQ 10
	I/O ports at d800 [size=256]
	I/O ports at dc40 [size=64]
	Kernel driver in use: Intel ICH
	Kernel modules: snd-intel8x0

The system has some odd log messages:

Jun 30 21:27:09 varda pulseaudio[2275]: alsa-util.c: snd_pcm_avail() returned a value that is exceptionally large: 4294954008 bytes (24347811 ms).
Jun 30 21:27:09 varda pulseaudio[2275]: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.

Removing pulseaudio was a successful workaround.  After disabling pulseaudio and rebooting, sound played fine with ALSA.
Comment 1 Lennart Poettering 2009-07-01 07:57:58 EDT
The ALSA driver seems to overflow in snd_pcm_avail(), reassigning to kernel.

Please paste data from alsa-info.sh --no-upload here.
Comment 2 Stan Trzmiel 2009-07-14 07:04:30 EDT
Created attachment 351574 [details]
output of my systems alsa-info

For me latest koji kernel (2.6.29.6-213.fc11.i686.PAE) broke audio experience.
It fails every few minutes with simple tasks like playing shoutcast stream with Amarok. Usualy KDE recovers after few seconds, but sometimes I have to kill PA and run it once again. Games (Nexuiz, UFO: AI) kill sound immidiately.
Previous kernel (kernel-PAE-2.6.29.5-191.fc11.i686) doesn't cause any problems at all.

Here's my alsa-info.
Comment 3 Stan Trzmiel 2009-07-14 07:10:40 EDT
Created attachment 351575 [details]
Messages log with lots of alsa related errors
Comment 4 Stan Trzmiel 2009-07-16 16:25:44 EDT
I can confirm my problems start with 2.6.29.6-213.fc11.i686.PAE kernel, I've downgraded it to 2.6.29.6-211.fc11.i686.PAE and problem does not occur.
Comment 5 Lennart Poettering 2009-07-24 20:28:48 EDT
*** Bug 513451 has been marked as a duplicate of this bug. ***
Comment 6 Bob Hill 2009-07-25 04:58:25 EDT
In confirmation of previous comments:
This problem does NOT occur with kernel-2.6.29.5-191.fc11.i586.
This problem DOES occur with kernel-2.6.29.6-213.fc11.i586: sound is unusable !!!
Comment 7 Lennart Poettering 2009-07-25 07:48:13 EDT
*** Bug 513484 has been marked as a duplicate of this bug. ***
Comment 8 Lennart Poettering 2009-07-25 16:57:16 EDT
*** Bug 513763 has been marked as a duplicate of this bug. ***
Comment 9 Daan Mastenbroek 2009-07-27 04:52:21 EDT
Confirmation of bug on nVidia nforce AC97 implementation.

lspci -vv info:

00:06.0 Multimedia audio controller: nVidia Corporation nForce3 250Gb AC'97 Audio Controller (rev a1)
	Subsystem: ASUSTeK Computer Inc. Device 812a
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0 (500ns min, 1250ns max)
	Interrupt: pin A routed to IRQ 20
	Region 0: I/O ports at e800 [size=256]
	Region 1: I/O ports at e400 [size=128]
	Region 2: Memory at ff6fb000 (32-bit, non-prefetchable) [size=4K]
	Capabilities: <access denied>
	Kernel driver in use: Intel ICH
	Kernel modules: snd-intel8x0

sound starts playing fine most of the time but crashes soon after that, sometimes sound is scrambled right away.
Comment 10 Daan Mastenbroek 2009-07-27 04:59:23 EDT
Additional info

Jul 27 10:21:08 daan pulseaudio[2406]: alsa-sink.c: Increasing wakeup watermark to 30.00 ms
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c: snd_pcm_avail() returned a value that is exceptionally large: 18446744073709519808 bytes (384307168036 ms).
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c: snd_pcm_dump():
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c: Hardware PCM card 0 'NVidia CK8S' device 0 subdevice 0
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c: Its setup is:
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   stream       : PLAYBACK
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   access       : MMAP_INTERLEAVED
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   format       : S16_LE
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   subformat    : STD
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   channels     : 2
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   rate         : 48000
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   exact rate   : 48000 (48000/1)
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   msbits       : 16
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   buffer_size  : 16384
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   period_size  : 16384
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   period_time  : 341333
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   tstamp_mode  : ENABLE
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   period_step  : 1
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   avail_min    : 16384
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   period_event : 0
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   start_threshold  : -1
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   stop_threshold   : 4611686018427387904
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   silence_threshold: 0
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   silence_size : 0
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   boundary     : 4611686018427387904
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   appl_ptr     : 745232
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   hw_ptr       : 720896
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c: snd_pcm_delay() returned a value that is exceptionally large: 492224 bytes (2563 ms).
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_intel8x0'. Please report this issue to the ALSA developers.
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c: snd_pcm_dump():
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c: Hardware PCM card 0 'NVidia CK8S' device 0 subdevice 0
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c: Its setup is:
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   stream       : PLAYBACK
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   access       : MMAP_INTERLEAVED
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   format       : S16_LE
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   subformat    : STD
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   channels     : 2
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   rate         : 48000
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   exact rate   : 48000 (48000/1)
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   msbits       : 16
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   buffer_size  : 16384
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   period_size  : 16384
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   period_time  : 341333
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   tstamp_mode  : ENABLE
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   period_step  : 1
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   avail_min    : 16384
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   period_event : 0
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   start_threshold  : -1
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   stop_threshold   : 4611686018427387904
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   silence_threshold: 0
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   silence_size : 0
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   boundary     : 4611686018427387904
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   appl_ptr     : 846032
Jul 27 10:21:09 daan pulseaudio[2406]: alsa-util.c:   hw_ptr       : 722976
Jul 27 10:21:13 daan pulseaudio[2406]: ratelimit.c: 2700 events suppressed
Jul 27 10:21:18 daan pulseaudio[2406]: ratelimit.c: 2899 events suppressed
Jul 27 10:21:23 daan pulseaudio[2406]: ratelimit.c: 2292 events suppressed
Jul 27 10:21:28 daan pulseaudio[2406]: ratelimit.c: 2896 events suppressed
Jul 27 10:21:33 daan pulseaudio[2406]: ratelimit.c: 3108 events suppressed
Jul 27 10:21:36 daan pulseaudio[2406]: cpulimit.c: Received request to terminate due to CPU overload.
Comment 11 Joel 2009-07-27 15:32:27 EDT
Note that this problem also occurs with kernel 217 from koji on Dell Inspiron 8500.
Comment 12 Joel 2009-07-28 17:12:49 EDT
Is this a duplicate of:

https://bugzilla.redhat.com/show_bug.cgi?id=506075

?
Comment 13 Jaroslav Kysela 2009-07-29 04:12:09 EDT

*** This bug has been marked as a duplicate of bug 506075 ***

Note You need to log in before you can comment on or make changes to this bug.