Bug 513484 - 100% cpu usage during playback, then playback abort.
100% cpu usage during playback, then playback abort.
Status: CLOSED DUPLICATE of bug 509054
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-23 16:26 EDT by condor
Modified: 2009-07-25 17:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-25 07:48:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pulseaudio -vvvv log (894.51 KB, text/plain)
2009-07-25 07:11 EDT, Gavin Simpson
no flags Details

  None (edit)
Description condor 2009-07-23 16:26:59 EDT
Description of problem:
Audio playback somewhen suddenly stops, cpu usage goes to 100% and the media file played kind of fastforwards. Noticed so far with Rhythmbox playing audio files, as well as videos played with Adobe's Flash player.

Version-Release number of selected component (if applicable):
$ yum list rhythmbox '*pulse*' '*gstreamer*' '*flash*' '*alsa*'
Geladene Plugins: dellsysidplugin2, refresh-packagekit
Installierte Pakete
PackageKit-gstreamer-plugin.i586    0.4.8-2.fc11         @updates               
alsa-lib.i586                       1.0.20-1.fc11        installed              
alsa-lib-devel.i586                 1.0.20-1.fc11        installed              
alsa-plugins-pulseaudio.i586        1.0.20-2.fc11        @updates               
alsa-utils.i586                     1.0.20-3.fc11        installed              
bluez-alsa.i586                     4.37-2.fc11          installed              
flash-plugin.i386                   10.0.22.87-release   installed              
gstreamer.i586                      0.10.23-2.fc11       installed              
gstreamer-ffmpeg.i586               0.10.7-2.fc11.1      installed              
gstreamer-plugins-bad.i586          0.10.13-3.fc11       @rpmfusion-free-updates
gstreamer-plugins-base.i586         0.10.23-3.fc11       @updates               
gstreamer-plugins-flumpegdemux.i586 0.10.15-6.fc11       installed              
gstreamer-plugins-good.i586         0.10.15-3.fc11       @updates               
gstreamer-plugins-ugly.i586         0.10.12-1.fc11       @rpmfusion-free-updates
gstreamer-python.i586               0.10.15-1.fc11       installed              
gstreamer-tools.i586                0.10.23-2.fc11       installed              
pulseaudio.i586                     0.9.15-14.fc11       installed              
pulseaudio-esound-compat.i586       0.9.15-14.fc11       installed              
pulseaudio-libs.i586                0.9.15-14.fc11       installed              
pulseaudio-libs-glib2.i586          0.9.15-14.fc11       installed              
pulseaudio-libs-zeroconf.i586       0.9.15-14.fc11       @updates               
pulseaudio-module-bluetooth.i586    0.9.15-14.fc11       installed              
pulseaudio-module-gconf.i586        0.9.15-14.fc11       installed              
pulseaudio-module-x11.i586          0.9.15-14.fc11       installed              
pulseaudio-utils.i586               0.9.15-14.fc11       installed              
rhythmbox.i586                      0.12.1-3.fc11        installed              
totem-gstreamer.i586                2.26.3-1.fc11        @updates               
wine-pulseaudio.i586                1.1.23-1.fc11        installed              
xine-lib-pulseaudio.i586            1.1.16.3-2.fc11      installed   

How reproducible:
Play some sound, for example...

Steps to Reproduce:
1. Start Rhythmbox.
2. Select some audio file (tested with .mp3 file).
3. Play it.
  
Actual results:
After 2 minutes or three, cpu usage goes up to 100% and playback stops. The Rhythmbox's position display fast-forwards till the end of the file, then the next one starts. The old one is marked as errorneous.

Expected results:
Audio file plays just fine.

Additional info:
When watching pulseaudio's statistics with paman, I notice a sudden explosion of the number of currently allocated memory blocks during this 100%-cpu-phase, from something around 300 to far over 800 blocks. paman then reports disconnection to the PA server.

Problems must have started with the updates that came in on July, 21st or 23rd.

Maybe related with bug 471964, but not sure, so I started a new report. I tried turning off the timer-based scheduling as mentioned there, but it made no difference.

Sink is "alsa_output.pci_8086_266e_sound_card_0".
Comment 1 Lennart Poettering 2009-07-24 20:52:16 EDT
Probably a broken sound driver.

Please open a seperate terminal. Run pulseaudio -k there, followed by pulseaudio -vvvv. Now try to reproduce and paste the last 50 lines or so that were generated in the terminal when you reproduced here.
Comment 2 Gavin Simpson 2009-07-25 07:11:35 EDT
Created attachment 355138 [details]
pulseaudio -vvvv log

I'm seeing the same behaviour after updating via yum yesterday (sound previously working). This is with Totem, Rhythmbox and flash in Firefox.

Following Lennart's suggestion, I played an ogg file via totem after having kille pulseaudio and then running pulseaudio -vvvv in a terminal. Sound works initially then stops and a large amount of messages printed to terminal, and totem eventually issues the following error message in a pop-up dialogue:

pa_stream_writable_size() failed: Connection terminated

The last 50 lines in the terminal are:

<many versions of the three lines prefixed with D:>
D: protocol-native.c: Requesting rewind due to rewrite.
D: alsa-sink.c: Requested to rewind 42260 bytes.
D: alsa-sink.c: Mhmm, actually there is nothing to rewind.
Hard CPU time limit exhausted, terminating forcibly.

The entire log is attached.

Software versions:
yum list totem '*pulsea*' '*gstreamer*' '*flash*' '*alsa*'
Loaded plugins: fastestmirror, presto, refresh-packagekit
Installed Packages
PackageKit-gstreamer-plugin.i586    0.4.8-2.fc11        installed              
alsa-lib.i586                       1.0.20-1.fc11       installed              
alsa-plugins-pulseaudio.i586        1.0.20-2.fc11       installed              
alsa-utils.i586                     1.0.20-3.fc11       installed              
flash-plugin.i386                   10.0.22.87-release  @adobe-linux-i386      
gstreamer.i586                      0.10.23-2.fc11      installed              
gstreamer-ffmpeg.i586               0.10.7-2.fc11.1     @rpmfusion-free-updates
gstreamer-plugins-bad.i586          0.10.13-3.fc11      @rpmfusion-free-updates
gstreamer-plugins-base.i586         0.10.23-3.fc11      installed              
gstreamer-plugins-flumpegdemux.i586 0.10.15-6.fc11      installed              
gstreamer-plugins-good.i586         0.10.15-3.fc11      installed              
gstreamer-plugins-ugly.i586         0.10.12-1.fc11      @rpmfusion-free-updates
gstreamer-python.i586               0.10.15-1.fc11      installed              
gstreamer-tools.i586                0.10.23-2.fc11      installed              
pulseaudio.i586                     0.9.15-14.fc11      installed              
pulseaudio-libs.i586                0.9.15-14.fc11      installed              
pulseaudio-libs-glib2.i586          0.9.15-14.fc11      installed              
pulseaudio-module-bluetooth.i586    0.9.15-14.fc11      installed              
pulseaudio-module-gconf.i586        0.9.15-14.fc11      installed              
pulseaudio-module-x11.i586          0.9.15-14.fc11      installed              
pulseaudio-utils.i586               0.9.15-14.fc11      installed              
totem.i586                          2.26.3-1.fc11       installed              
totem-gstreamer.i586                2.26.3-1.fc11       installed              
xine-lib-pulseaudio.i586            1.1.16.3-2.fc11     installed

Hardware:
http://www.smolts.org/show?uuid=pub_91b62626-6cda-4ca8-9726-2d684fc62e9c

Let me know if you need further info.
Comment 3 Lennart Poettering 2009-07-25 07:48:13 EDT
Your driver is broken.

*** This bug has been marked as a duplicate of bug 509054 ***
Comment 4 Gavin Simpson 2009-07-25 17:17:09 EDT
Thanks for confirming this Lennart, and that the problem lies within the recent kernel update. Much appreciated.

Note You need to log in before you can comment on or make changes to this bug.