Bug 513546 - python-daemon requires lockfile
Summary: python-daemon requires lockfile
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-daemon
Version: 12
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Thomas Spura
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 513544 544581
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-07-24 05:58 UTC by Silas Sewell
Modified: 2011-09-17 22:00 UTC (History)
4 users (show)

Fixed In Version: python-daemon-1.5.2-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-14 01:20:23 UTC
Type: ---


Attachments (Terms of Use)

Description Silas Sewell 2009-07-24 05:58:40 UTC
Description of problem:

python-daemon requires the lockfile module, it is used in "pidlockfile.py".

  18 
  19 from lockfile import (
  20     LockBase,
  21     AlreadyLocked, LockFailed,
  22     NotLocked, NotMyLock,
  23     )
  24 

Version-Release number of selected component (if applicable):

  Version     : 1.4.6
  Release     : 1.fc12

How reproducible:

  Always.

Steps to Reproduce:

  1. python -c 'from daemon import pidlockfile'
  
Actual results:

  Traceback (most recent call last):
    File "<string>", line 1, in <module>
    File "/usr/lib/python2.6/site-packages/daemon/pidlockfile.py", line 19, in <module>
      from lockfile import (
  ImportError: No module named lockfile

Expected results:

  No error.

Additional info:

I packaged python-lockfile to fix this, the review is available at https://bugzilla.redhat.com/show_bug.cgi?id=513544

Comment 1 Silas Sewell 2009-07-24 23:39:15 UTC
The package is in devel, you can now just add:

Requires: python-lockfile

Thanks,

Comment 2 Luke Macken 2009-10-07 19:06:14 UTC
Silas,
can we also branch python-lockfile for F-11 and EL-5 as well?  Thanks

Comment 3 Silas Sewell 2009-11-03 15:42:09 UTC
Luke,

Sorry about the slow response, I'll review the code tonight and make sure its compatible with Python 2.4.

Comment 5 Bug Zapper 2009-11-16 11:05:10 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 7 Thomas Spura 2009-12-05 14:47:07 UTC
In CVS the test suite is broken, because of this and a missing minimock.

Review is at: bug# 544581

Comment 8 Fedora Update System 2009-12-28 18:04:59 UTC
python-daemon-1.5.2-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/python-daemon-1.5.2-1.fc12

Comment 9 Fedora Update System 2009-12-29 18:59:00 UTC
python-daemon-1.5.2-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-daemon'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13796

Comment 10 Fedora Update System 2010-01-14 01:20:18 UTC
python-daemon-1.5.2-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2011-08-22 23:03:52 UTC
python-daemon-1.5.2-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/python-daemon-1.5.2-1.el6

Comment 12 Fedora Update System 2011-09-17 22:00:51 UTC
python-daemon-1.5.2-1.el6 has been pushed to the Fedora EPEL 6 stable repository.


Note You need to log in before you can comment on or make changes to this bug.