This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 513744 - Swig update required
Swig update required
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: swig (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: 478372
  Show dependency treegraph
 
Reported: 2009-07-25 02:54 EDT by D Haley
Modified: 2013-04-30 19:43 EDT (History)
6 users (show)

See Also:
Fixed In Version: 1.3.39-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-03 10:04:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description D Haley 2009-07-25 02:54:42 EDT
Please update swig to latest on F10. Swig is generating invalid c++ code on f10 for one of my packages currently under review (bug 478372). However swig works fine under F11, so I suspect this has been fixed in between F10 and F11 versions of swig.

F10, latest:
$ rpm -q swig
swig-1.3.35-2.fc10.i386

SWIG Packageinfo:
http://koji.fedoraproject.org/koji/packageinfo?packageID=400

Mathgl:
F10 (FAIL): http://koji.fedoraproject.org/koji/getfile?taskID=1508388&name=build.log
F11 (OK): http://koji.fedoraproject.org/koji/taskinfo?taskID=1508692

Error:
mgl_octave.cpp: In member function 'int<unnamed>::Swig::hash_voidptr::operator()(void*) const':
mgl_octave.cpp:854: error: cast from 'void*' to 'int' loses precision


   852     struct hash_voidptr {
   853       int operator() (void *p) const {
   854         return (int) p;
   855       }
   856     };
   
   Those shouldn't be ints under x86_64, but should be longs.
Comment 1 Fedora Update System 2009-07-29 11:07:07 EDT
swig-1.3.39-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/swig-1.3.39-1.fc10
Comment 2 Fedora Update System 2009-07-31 14:05:23 EDT
swig-1.3.39-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 3 Alex Lancaster 2009-07-31 23:00:44 EDT
Update breaks deps, re-opening.

sudo yum update

--> Running transaction check
---> Package swig.i386 0:1.3.39-1.fc10 set to be updated
--> Processing Dependency: perl(example) for package: swig-1.3.39-1.fc10.i386
--> Processing Dependency: perl(the) for package: swig-1.3.39-1.fc10.i386
--> Processing Dependency: perl(it) for package: swig-1.3.39-1.fc10.i386
--> Processing Dependency: perl(argv) for package: swig-1.3.39-1.fc10.i386
--> Running transaction check
---> Package jython-demo.i386 0:2.2.1-0.1.Release_2_2_1.1.2.fc10 set to be updated
---> Package swig.i386 0:1.3.39-1.fc10 set to be updated
--> Processing Dependency: perl(the) for package: swig-1.3.39-1.fc10.i386
--> Processing Dependency: perl(it) for package: swig-1.3.39-1.fc10.i386
--> Processing Dependency: perl(argv) for package: swig-1.3.39-1.fc10.i386
--> Finished Dependency Resolution
swig-1.3.39-1.fc10.i386 from updates has depsolving problems
  --> Missing Dependency: perl(it) is needed by package swig-1.3.39-1.fc10.i386 (updates)
swig-1.3.39-1.fc10.i386 from updates has depsolving problems
  --> Missing Dependency: perl(argv) is needed by package swig-1.3.39-1.fc10.i386 (updates)
swig-1.3.39-1.fc10.i386 from updates has depsolving problems
  --> Missing Dependency: perl(the) is needed by package swig-1.3.39-1.fc10.i386 (updates)
Error: Missing Dependency: perl(the) is needed by package swig-1.3.39-1.fc10.i386 (updates)
Error: Missing Dependency: perl(it) is needed by package swig-1.3.39-1.fc10.i386 (updates)
Error: Missing Dependency: perl(argv) is needed by package swig-1.3.39-1.fc10.i386 (updates)
Comment 4 Rick Richardson 2009-08-01 08:21:41 EDT
$ root yum update swig
Loaded plugins: refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package swig.i386 0:1.3.39-1.fc10 set to be updated
--> Processing Dependency: perl(example) for package: swig-1.3.39-1.fc10.i386
--> Processing Dependency: perl(the) for package: swig-1.3.39-1.fc10.i386
--> Processing Dependency: perl(it) for package: swig-1.3.39-1.fc10.i386
--> Processing Dependency: perl(argv) for package: swig-1.3.39-1.fc10.i386
--> Running transaction check
---> Package jython-demo.i386 0:2.2.1-0.1.Release_2_2_1.1.2.fc10 set to be updated
--> Processing Dependency: jython = 2.2.1-0.1.Release_2_2_1.1.2.fc10 for package: jython-demo-2.2.1-0.1.Release_2_2_1.1.2.fc10.i386
---> Package swig.i386 0:1.3.39-1.fc10 set to be updated
--> Processing Dependency: perl(the) for package: swig-1.3.39-1.fc10.i386
--> Processing Dependency: perl(it) for package: swig-1.3.39-1.fc10.i386
--> Processing Dependency: perl(argv) for package: swig-1.3.39-1.fc10.i386
--> Running transaction check
---> Package jython.i386 0:2.2.1-0.1.Release_2_2_1.1.2.fc10 set to be updated
--> Processing Dependency: libreadline-java >= 0.8.0-16 for package: jython-2.2.1-0.1.Release_2_2_1.1.2.fc10.i386
--> Processing Dependency: oro for package: jython-2.2.1-0.1.Release_2_2_1.1.2.fc10.i386
--> Processing Dependency: mysql-connector-java for package: jython-2.2.1-0.1.Release_2_2_1.1.2.fc10.i386
---> Package swig.i386 0:1.3.39-1.fc10 set to be updated
--> Processing Dependency: perl(the) for package: swig-1.3.39-1.fc10.i386
--> Processing Dependency: perl(it) for package: swig-1.3.39-1.fc10.i386
--> Processing Dependency: perl(argv) for package: swig-1.3.39-1.fc10.i386
--> Running transaction check
---> Package jakarta-oro.i386 0:2.0.8-4.2.fc10 set to be updated
---> Package libreadline-java.i386 0:0.8.0-22.fc10 set to be updated
---> Package mysql-connector-java.i386 1:3.1.12-6.fc10 set to be updated
--> Processing Dependency: jta >= 1.0 for package: 1:mysql-connector-java-3.1.12-6.fc10.i386
---> Package swig.i386 0:1.3.39-1.fc10 set to be updated
--> Processing Dependency: perl(the) for package: swig-1.3.39-1.fc10.i386
--> Processing Dependency: perl(it) for package: swig-1.3.39-1.fc10.i386
--> Processing Dependency: perl(argv) for package: swig-1.3.39-1.fc10.i386
--> Running transaction check
---> Package geronimo-specs-compat.i386 0:1.0-2.M2.fc10 set to be updated
--> Processing Dependency: geronimo-specs = 1.0-2.M2.fc10 for package: geronimo-specs-compat-1.0-2.M2.fc10.i386
---> Package swig.i386 0:1.3.39-1.fc10 set to be updated
--> Processing Dependency: perl(the) for package: swig-1.3.39-1.fc10.i386
--> Processing Dependency: perl(it) for package: swig-1.3.39-1.fc10.i386
--> Processing Dependency: perl(argv) for package: swig-1.3.39-1.fc10.i386
--> Running transaction check
---> Package geronimo-specs.i386 0:1.0-2.M2.fc10 set to be updated
--> Processing Dependency: mx4j >= 2.0.1 for package: geronimo-specs-1.0-2.M2.fc10.i386
---> Package swig.i386 0:1.3.39-1.fc10 set to be updated
--> Processing Dependency: perl(the) for package: swig-1.3.39-1.fc10.i386
--> Processing Dependency: perl(it) for package: swig-1.3.39-1.fc10.i386
--> Processing Dependency: perl(argv) for package: swig-1.3.39-1.fc10.i386
--> Running transaction check
---> Package mx4j.i386 1:3.0.1-7.8.fc10 set to be updated
--> Processing Dependency: javamail >= 1.2-5jpp for package: 1:mx4j-3.0.1-7.8.fc10.i386
--> Processing Dependency: bcel >= 5.0 for package: 1:mx4j-3.0.1-7.8.fc10.i386
--> Processing Dependency: axis >= 1.1 for package: 1:mx4j-3.0.1-7.8.fc10.i386
--> Processing Dependency: jaf for package: 1:mx4j-3.0.1-7.8.fc10.i386
---> Package swig.i386 0:1.3.39-1.fc10 set to be updated
--> Processing Dependency: perl(the) for package: swig-1.3.39-1.fc10.i386
--> Processing Dependency: perl(it) for package: swig-1.3.39-1.fc10.i386
--> Processing Dependency: perl(argv) for package: swig-1.3.39-1.fc10.i386
--> Running transaction check
---> Package axis.i386 0:1.2.1-4.1.fc10 set to be updated
--> Processing Dependency: jakarta-commons-httpclient for package: axis-1.2.1-4.1.fc10.i386
--> Processing Dependency: wsdl4j for package: axis-1.2.1-4.1.fc10.i386
--> Processing Dependency: jakarta-commons-discovery for package: axis-1.2.1-4.1.fc10.i386
---> Package bcel.i386 0:5.2-5.1.fc10 set to be updated
--> Processing Dependency: regexp for package: bcel-5.2-5.1.fc10.i386
---> Package classpathx-jaf.i386 0:1.0-12.fc10 set to be updated
---> Package classpathx-mail.i386 0:1.1.1-7.1.fc10 set to be updated
---> Package swig.i386 0:1.3.39-1.fc10 set to be updated
--> Processing Dependency: perl(the) for package: swig-1.3.39-1.fc10.i386
--> Processing Dependency: perl(it) for package: swig-1.3.39-1.fc10.i386
--> Processing Dependency: perl(argv) for package: swig-1.3.39-1.fc10.i386
--> Running transaction check
---> Package jakarta-commons-discovery.i386 1:0.4-3.2.fc10 set to be updated
---> Package jakarta-commons-httpclient.i386 1:3.1-0.3.fc10 set to be updated
---> Package regexp.i386 0:1.5-2.2.fc10 set to be updated
---> Package swig.i386 0:1.3.39-1.fc10 set to be updated
--> Processing Dependency: perl(the) for package: swig-1.3.39-1.fc10.i386
--> Processing Dependency: perl(it) for package: swig-1.3.39-1.fc10.i386
--> Processing Dependency: perl(argv) for package: swig-1.3.39-1.fc10.i386
---> Package wsdl4j.i386 0:1.5.2-5.4.fc10 set to be updated
--> Finished Dependency Resolution
swig-1.3.39-1.fc10.i386 from updates has depsolving problems
  --> Missing Dependency: perl(it) is needed by package swig-1.3.39-1.fc10.i386 (updates)
swig-1.3.39-1.fc10.i386 from updates has depsolving problems
  --> Missing Dependency: perl(argv) is needed by package swig-1.3.39-1.fc10.i386 (updates)
swig-1.3.39-1.fc10.i386 from updates has depsolving problems
  --> Missing Dependency: perl(the) is needed by package swig-1.3.39-1.fc10.i386 (updates)
Error: Missing Dependency: perl(the) is needed by package swig-1.3.39-1.fc10.i386 (updates)
Error: Missing Dependency: perl(it) is needed by package swig-1.3.39-1.fc10.i386 (updates)
Error: Missing Dependency: perl(argv) is needed by package swig-1.3.39-1.fc10.i386 (updates)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
$
Comment 5 Brian Morrison 2009-08-02 05:13:25 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=514983

is a related bug concerning the buggy spec file for this swig build.

The F11 spec file builds a correct rpm, it's just F10 that has the problem.
Comment 6 Adam Tkac 2009-08-03 10:04:07 EDT
(In reply to comment #3)
> Update breaks deps, re-opening.

Let's track this issue under bug #514983.

Note You need to log in before you can comment on or make changes to this bug.