Bug 51375 - assumes running under gnome with esd
assumes running under gnome with esd
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
: 51376 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-09 17:07 EDT by Gene Czarcinski
Modified: 2015-01-07 18:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-10 14:32:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2001-08-09 17:07:12 EDT
Description of Problem:
up2date assumes it is running under gnome with esd

How Reproducible:
alwyas

Steps to Reproduce:
1. run up2date from regular user
2. 
3. 

Actual Results:
esd erros

Expected Results:
no esd errors

Other info:
Does not occur running up2date as root.
Comment 1 Gene Czarcinski 2001-08-09 17:09:00 EDT
*** Bug 51376 has been marked as a duplicate of this bug. ***
Comment 2 Glen Foster 2001-08-10 16:03:29 EDT
This defect is considered MUST-FIX for Fairfax.
Comment 3 Cristian Gafton 2001-08-10 16:58:15 EDT
Assigned to the owner of component
Comment 4 Adrian Likins 2001-08-10 17:06:11 EDT
hmm, weird.

up2date of course, doesnt do anything with sound, /dev/dsp, /dev/esd,
esd, or otherwise, so I'm a little confused as to what this error
message indicates. 

Do you have "sounds for system events" enabled for gnome stuff?
Is esd running for that user?

Could you provide a copy of the esd error your getting? I'm not having
much luck attempting to duplicate this.
Comment 5 Lamar Owen 2001-09-10 12:05:01 EDT
Possibly related:
up2date won't run under KDE as normal user.  KDE brings up the dialog 
requesting the root password, and a dialog displays mentioning the beta site's 
RHCN stuff.  Clicking OK on the dialog clears the dialog, and up2date doesn't 
open another window, and according to ps ax is still running.  After a while, the 
error message (if run from a konsole):
Error communicating with server.  The message was:
Connection aborted by the user
Error communicating with server.  The message was:
Connection timed out
is spit out and up2date terminates without ever providing a dialog of any kind.
Comment 6 Preston Brown 2001-09-10 14:32:17 EDT
up2date runs under KDE for me just fine, BTW.  I don't think there is a bug 
here.  Perhaps a beta RHN server misconfiguration, but no bug.
Comment 7 Adrian Likins 2002-03-26 18:15:33 EST
I think any of the issues related to this should be cleard
up by now in current versions.

If thats not the case, please reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.