Bug 51380 - ksconfig crashes when invoked
ksconfig crashes when invoked
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ksconfig (Show other bugs)
7.1
noarch Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-09 17:57 EDT by ctolley
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-09 17:57:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ctolley 2001-08-09 17:57:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2smp i686)

Description of problem:
Whether starting via the X menu item (Program -> System -> Kickstart
Configurator) or via command-line:

/usr/sbin/ksconfig

ksconfig returns the following error:

Traceback (innermost last):
  File "/usr/share/ksconfig/ksconfig.py", line 387, in ?
    timeCombo.list.select_item(select)
NameError: select

I'm not a Python programmer, but I gambled and commented out line 387 and
the application started, and appears to create valid kickstart config
files, but I don't know the overall impact of leaving that line commented
out.

How reproducible:
Always

Steps to Reproduce:
1. Install Kickstart 1.2-1 and ksconfig 1.2-1 via rpm
2. From X, choose Kickstart Configurator from (Programs -> System ->
Kickstart Configurator), or invoke from a terminal program (Eterm or xterm,
etc.).
3. Invoking from a terminal client lets you immediately see the error msg,
or you can CTRL-ALT-F1 over to the 1st TTY to see the error there.


Actual Results:  Traceback (innermost last):
  File "/usr/share/ksconfig/ksconfig.py", line 387, in ?
    timeCombo.list.select_item(select)
NameError: select


Expected Results:  Either provide an updated package, patch or snippit of
code that will correct this error.

Additional info:
Comment 1 Brent Fox 2001-08-10 16:04:29 EDT
This is a dupe of bug #37753.  You have found a correct workaround.  I could
provide you a fix, but it would just consist of the same change that you made. 
You sound like a Python programmer to me.  ;)

Anyway, ksconfig has gone through a major rewrite in regards to interface and
things like that.  The next release will not have this problem.

Note You need to log in before you can comment on or make changes to this bug.