Bug 514106 - intel flickers badly on screen updates
intel flickers badly on screen updates
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 514985 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-27 22:32 EDT by Bill Nottingham
Modified: 2014-03-16 23:19 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-03 22:08:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2009-07-27 22:32:00 EDT
Description of problem:

Upon booting the rawhide kernel, I have a perfectly stable X image... as long as the screen is not updating. On any update, the image jumps about 500 pixels to the right for a tenth of second before snapping back. It's pretty trippy.

Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-1.6.1.901-1.fc11.x86_64
xorg-x11-drv-intel-2.7.0-7.fc11.x86_64
kernel-2.6.31-0.94.rc4.fc12.x86_64

How reproducible:

Once is enough

Steps to Reproduce:
1. Install new kernel.
2. Reboot.
  
Actual results:

Chaos on any screen updates.

Expected results:

Happy X.

Additional info:

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

[notting@nostromo: ~]$ xrandr 
Screen 0: minimum 320 x 200, current 1400 x 1050, maximum 4096 x 4096
VGA1 disconnected (normal left inverted right x axis y axis)
LVDS1 connected 1400x1050+0+0 (normal left inverted right x axis y axis) 287mm x 215mm
   1400x1050      60.0*+   50.0  
DVI1 disconnected (normal left inverted right x axis y axis)
Comment 1 Matthew Garrett 2009-07-27 22:47:05 EDT
Hmm. This was just before I added the PM code, so I think this is Kristian's problem rather than mine.
Comment 2 Bill Nottingham 2009-07-28 10:37:24 EDT
Backing down to 2.6.30-6.fc12 works. Haven't tried anything else in between yet.
Comment 3 Bill Nottingham 2009-08-03 12:36:47 EDT
*** Bug 514985 has been marked as a duplicate of this bug. ***
Comment 4 Bill Nottingham 2009-08-03 12:38:03 EDT
Persists in .118.
Comment 5 Warren Togami 2009-08-03 12:44:26 EDT
krh suggested that this could be an issue with the "fifo watermark" that Jesse Barnes @ Intel is trying to fix.
Comment 6 Adam Jackson 2009-08-03 15:08:25 EDT
kernel-2.6.31-0.123.rc5.git2.fc12 or later includes jesse's watermark fixes.  Give that a try?
Comment 7 Bill Nottingham 2009-08-03 22:08:14 EDT
0.122.rc5 WFM.

Note You need to log in before you can comment on or make changes to this bug.