Bug 514985 - intel 945 KMS horizontal flipping glitch
intel 945 KMS horizontal flipping glitch
Status: CLOSED DUPLICATE of bug 514106
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-07-31 14:45 EDT by Warren Togami
Modified: 2009-08-03 12:36 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-03 12:36:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2009-07-31 14:45:16 EDT
http://people.redhat.com/wtogami/temp/intel-945-horz-render-glitch.mov

I noticed during early July while trying a rawhide LiveCD that the display was behaving very strangely like in the above video.  During certain render operations, everything on the screen would "flip" horizontally in an annoying fashion.

* This happens during KMS boot while text flies by, before X has run.
* This happens while X is running.
* It happens continuously if you run gnome-terminal and have text fly by in your terminal.  As long as the text is moving, the entire screen exhibits this glitch.

It is impossible to upgrade my laptop to rawhide while this bug exists.

kernel-2.6.31-0.112.rc4.git3.fc12 (both i686 and x86_64 effected)
xorg-x11-drv-intel-2.8.0-2.fc12
libdrm-2.4.12-0.6.fc12
Comment 1 Warren Togami 2009-07-31 14:47:02 EDT
krh mentioned that the "fifo watermark" work might be related to this.
Comment 2 Bill Nottingham 2009-08-03 12:36:47 EDT

*** This bug has been marked as a duplicate of bug 514106 ***

Note You need to log in before you can comment on or make changes to this bug.