Bug 514472 - dumpxml/edit should never show dev='vnet%d'
dumpxml/edit should never show dev='vnet%d'
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-29 05:42 EDT by Gianluca Sforna
Modified: 2009-07-29 07:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-29 05:47:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gianluca Sforna 2009-07-29 05:42:04 EDT
While diagnosing bug 514228 it was suggested to use virsh to edit the VM's config and remove the <target> line from:

    <interface type='bridge'>
     <mac address='54:52:00:49:73:9a'/>
     <source bridge='br0'/>
     <target dev='vnet%d'/>
   </interface>

which I did. The problem is that after restarting the guest the line is back in the config file.

libvirt-0.6.2-13.fc11.x86_64
Comment 1 Daniel Berrange 2009-07-29 05:47:26 EDT
This is intended behaviour. We expose the configured NIC backend device in the XML whenever it is available.

Removing this line yourself should not have impacted any functional behaviour, since libvirt already ignores any requested device whose name starts with the string 'vnet'.
Comment 2 Mark McLoughlin 2009-07-29 07:55:48 EDT
Huh?

How does it make sense for libvirt to include 'vnet%d' in dumpxml output?

Note You need to log in before you can comment on or make changes to this bug.