Bug 515063 - It looks like overriding the partition size limit is broken in rawhide
Summary: It looks like overriding the partition size limit is broken in rawhide
Keywords:
Status: CLOSED DUPLICATE of bug 516338
Alias: None
Product: Fedora
Classification: Fedora
Component: livecd-tools
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-01 15:22 UTC by Bruno Wolff III
Modified: 2009-08-14 14:08 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-14 14:08:13 UTC


Attachments (Terms of Use)

Description Bruno Wolff III 2009-08-01 15:22:40 UTC
Description of problem:
I got the following error while trying to do a test build of the games spin in rawhide:

[root@games1 livegames]# livecd-creator -v -c /usr/share/spin-kickstarts/fedora-livedvd-games.ks -f "Custom-Live-games-i686" -t /home/livecd/tmp --cache=/home/livecd/cache
Traceback (most recent call last):
  File "/usr/bin/livecd-creator", line 140, in <module>
    sys.exit(main())
  File "/usr/bin/livecd-creator", line 112, in main
    ks = imgcreate.read_kickstart(options.kscfg)
  File "/usr/lib/python2.6/site-packages/imgcreate/kickstart.py", line 61, in read_kickstart
    "'%s' : %s" % (path, e))
imgcreate.errors.KickstartError/usr/lib/python2.6/site-packages/imgcreate/errors.py:40: DeprecationWarning: BaseException.message has been deprecated as of Python 2.6
  return str(self.message)
: Failed to parse kickstart file '/usr/share/spin-kickstarts/fedora-livedvd-games.ks' : A partition with the mountpoint / has already been defined.

I suspect this is due to the games spin needing to override the standard DVD spin size limit.

Version-Release number of selected component (if applicable):
livecd-tools-025-1.fc12.i686

How reproducible:
Seems to happen every time.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Kevin Fenzi 2009-08-06 20:32:01 UTC
This also happens to the electronics-lab spin in rawhide.

Comment 2 Jeroen van Meeuwen 2009-08-10 12:57:55 UTC
This is actually caused by pykickstart: see #516338

Comment 3 Jeremy Katz 2009-08-14 14:08:13 UTC

*** This bug has been marked as a duplicate of bug 516338 ***


Note You need to log in before you can comment on or make changes to this bug.